Bug 10863 - ld-linux.so.2 loops, eating CPU. Must be killed manually.
Summary: ld-linux.so.2 loops, eating CPU. Must be killed manually.
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: ld.so   
(Show other bugs)
Version: 6.1
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Cristian Gafton
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-04-16 22:13 UTC by Bryce Nesbitt
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-04-17 15:10:54 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Bryce Nesbitt 2000-04-16 22:13:10 UTC
Sometimes, usually on the exit of Communicator (version 4.61), I notice the
CPU bar is pegged and the machine is slow.  The problem is always
ld-linux.so.2.  Here is the top of a "top".

  3:22pm  up 1 day, 25 min,  1 user,  load average: 1.13, 1.41, 1.26
70 processes: 65 sleeping, 4 running, 1 zombie, 0 stopped
CPU states: 98.6% user,  1.3% system,  0.0% nice,  0.0% idle
Mem:  127760K av, 124276K used,   3484K free,  57692K shrd,   2620K buff
Swap: 133016K av,    416K used, 132600K free                 48588K cached

 PID USER  PRI NI SIZE RSS SHARE STAT LIB %CPU %MEM  TIME COMMAND
1118 bryce 17  0 30480 29M  9248 R    18M 97.2 23.8 1315m ld-linux.so.2

This happens about once a week under daily use.  I must kill -9 the
process.  Kill -6 is not enough.  Other coworkers see the same problem.  We
have not tried with RH 6.2 yet.

         -Bryce

Comment 1 Bryce Nesbitt 2000-04-16 22:13:59 UTC
(And won't try with 6.2 -- we're upgrade shy here)

Comment 2 Bill Nottingham 2000-04-17 15:10:59 UTC
This is netscape dying; you can solve this (sort of)
by not running netscape against the compatibility libs.
(rpm -e compat-libs compat-glibc will solve this; alternatively,
you can upgrade to the latest netscape package (such as the
4.72 packages), or edit
/usr/bin/netscape.)

This could, however, cause other instabilities.


Note You need to log in before you can comment on or make changes to this bug.