Bug 108655 - Bison fails to run without m4 installed, but no dependency exists
Bison fails to run without m4 installed, but no dependency exists
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: bison (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Roland McGrath
:
: 109370 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-30 17:33 EST by Dan Tucny
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version: 1.875-6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-11-05 19:56:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dan Tucny 2003-10-30 17:33:05 EST
Description of problem: If bison is installed but m4 is not, bison fails. Bison
does not have an RPM dependency on m4.


Version-Release number of selected component (if applicable):


How reproducible: every time


Steps to Reproduce:
1. Install bison package
2. Remove m4 package if already installed
3. Run bison against a file
    
Actual results:
bison terminates and the message 'Broken pipe' is displayed.

Expected results:
bison would process the input file and write to the output file.

Additional info:
Comment 1 Dan Tucny 2003-10-30 17:33:44 EST
strace of bison run without m4

# strace bison -v ast_expr.y --name-prefix=ast_yy -o ast_expr.c
execve("/usr/bin/bison", ["bison", "-v", "ast_expr.y", "--name-prefix=ast_yy",
"-o", "ast_expr.c"], [/* 23 vars */]) = 0
uname({sys="Linux", node="oak", ...}) = 0
brk(0)                                  = 0x9389000
old_mmap(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) =
0x3ff6f000
open("/etc/ld.so.preload", O_RDONLY)    = -1 ENOENT (No such file or directory)
open("/etc/ld.so.cache", O_RDONLY)      = 3
fstat64(3, {st_mode=S_IFREG|0644, st_size=19903, ...}) = 0
old_mmap(NULL, 19903, PROT_READ, MAP_PRIVATE, 3, 0) = 0x3ff03000
close(3)                                = 0
open("/lib/libc.so.6", O_RDONLY)        = 3
read(3, "\177ELF\1\1\1\0\0\0\0\0\0\0\0\0\3\0\3\0\1\0\0\0\24L3\000"..., 512) = 512
fstat64(3, {st_mode=S_IFREG|0755, st_size=1470096, ...}) = 0
old_mmap(0x31f000, 1194308, PROT_READ|PROT_EXEC, MAP_PRIVATE, 3, 0) = 0x31f000
old_mmap(0x43d000, 12288, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_FIXED, 3,
0x11d000) = 0x43d000
old_mmap(0x440000, 10564, PROT_READ|PROT_WRITE,
MAP_PRIVATE|MAP_FIXED|MAP_ANONYMOUS, -1, 0) = 0x440000
close(3)                                = 0
munmap(0x3ff03000, 19903)               = 0
brk(0)                                  = 0x9389000
brk(0x93aa000)                          = 0x93aa000
brk(0)                                  = 0x93aa000
open("/usr/lib/locale/locale-archive", O_RDONLY|O_LARGEFILE) = 3
fstat64(3, {st_mode=S_IFREG|0644, st_size=33513072, ...}) = 0
mmap2(NULL, 2097152, PROT_READ, MAP_PRIVATE, 3, 0) = 0x3ff70000
close(3)                                = 0
open("ast_expr.y", O_RDONLY)            = 3
fstat64(3, {st_mode=S_IFREG|0644, st_size=13686, ...}) = 0
old_mmap(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) =
0x40170000
read(3, "%{\n/* Written by Pace Willisson "..., 8192) = 8192
open("/usr/lib/gconv/gconv-modules.cache", O_RDONLY) = 4
fstat64(4, {st_mode=S_IFREG|0644, st_size=21436, ...}) = 0
old_mmap(NULL, 21436, PROT_READ, MAP_SHARED, 4, 0) = 0x40171000
close(4)                                = 0
read(3, "alue (b);\n\treturn r;\n}\n\nstatic s"..., 8192) = 5494
read(3, "", 4096)                       = 0
read(3, "", 8192)                       = 0
read(3, "", 8192)                       = 0
close(3)                                = 0
munmap(0x40170000, 4096)                = 0
old_mmap(NULL, 135168, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) =
0x3ff17000
old_mmap(NULL, 135168, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) =
0x3ff3b000
old_mmap(NULL, 135168, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) =
0x40177000
open("/usr/share/locale/locale.alias", O_RDONLY) = 3
fstat64(3, {st_mode=S_IFREG|0644, st_size=2601, ...}) = 0
old_mmap(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) =
0x40170000
read(3, "# Locale name alias data base.\n#"..., 4096) = 2601
read(3, "", 4096)                       = 0
close(3)                                = 0
munmap(0x40170000, 4096)                = 0
open("/usr/share/locale/en_GB.UTF-8/LC_MESSAGES/bison.mo", O_RDONLY) = -1 ENOENT
(No such file or directory)
open("/usr/share/locale/en_GB.utf8/LC_MESSAGES/bison.mo", O_RDONLY) = -1 ENOENT
(No such file or directory)
open("/usr/share/locale/en_GB/LC_MESSAGES/bison.mo", O_RDONLY) = -1 ENOENT (No
such file or directory)
open("/usr/share/locale/en.UTF-8/LC_MESSAGES/bison.mo", O_RDONLY) = -1 ENOENT
(No such file or directory)
open("/usr/share/locale/en.utf8/LC_MESSAGES/bison.mo", O_RDONLY) = -1 ENOENT (No
such file or directory)
open("/usr/share/locale/en/LC_MESSAGES/bison.mo", O_RDONLY) = -1 ENOENT (No such
file or directory)
open("ast_expr.output", O_WRONLY|O_CREAT|O_TRUNC, 0666) = 3
fstat64(3, {st_mode=S_IFREG|0644, st_size=0, ...}) = 0
old_mmap(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) =
0x3ff5c000
write(3, "Grammar\n\n    0 $accept: start $e"..., 4096) = 4096
write(3, "    TOKEN  shift, and go to stat"..., 4096) = 4096
write(3, "-\' expr\n   14     | expr . \'*\' e"..., 4096) = 4096
write(3, "| expr . \'%\' expr\n   17     | ex"..., 2226) = 2226
close(3)                                = 0
munmap(0x3ff5c000, 4096)                = 0
open("/usr/share/bison/m4sugar/m4sugar.m4", O_RDONLY) = 3
close(3)                                = 0
rt_sigaction(SIGCHLD, {SIG_DFL}, {SIG_DFL}, 8) = 0
pipe([3, 4])                            = 0
pipe([5, 6])                            = 0
vfork()                                 = 31487
close(3)                                = 0
close(6)                                = 0
fcntl64(4, F_GETFL)                     = 0x1 (flags O_WRONLY)
fstat64(4, {st_mode=S_IFIFO|0600, st_size=0, ...}) = 0
old_mmap(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) =
0x40170000
_llseek(4, 0, 0xbfee5728, SEEK_CUR)     = -1 ESPIPE (Illegal seek)
write(4, "m4_init()\nm4_define([b4_actions]"..., 4096) = -1 EPIPE (Broken pipe)
--- SIGPIPE (Broken pipe) @ 0 (0) ---
+++ killed by SIGPIPE +++

Comment 2 Roland McGrath 2003-10-30 18:08:06 EST
Thanks for the report.  I'll add the dependency to the rpm.
Comment 3 Roland McGrath 2003-11-05 19:56:34 EST
A new package with the m4 dependency should appear in the next rawhide
update.
Comment 4 Michael Schwendt 2003-11-07 12:41:52 EST
*** Bug 109370 has been marked as a duplicate of this bug. ***
Comment 5 Thomas Vander Stichele 2004-02-06 13:35:05 EST
just spent three hours debugging the same issue.  thanks for getting
this fixed for later releases.  please release an update :)

Note You need to log in before you can comment on or make changes to this bug.