Bug 108666 - Perl MakeMaker builds incorrect documentation install sections
Perl MakeMaker builds incorrect documentation install sections
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: perl (Show other bugs)
2.1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jason Vas Dias
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-30 18:31 EST by Jason Witt
Modified: 2007-11-30 17:06 EST (History)
0 users

See Also:
Fixed In Version: perl-5.6.1-37.1.99ent
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-21 17:05:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch with correct installation dirs for documentation (7.78 KB, patch)
2003-10-30 18:42 EST, Jason Witt
no flags Details | Diff

  None (edit)
Description Jason Witt 2003-10-30 18:31:58 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20031017

Description of problem:
MakeMaker creates incorrect documentation installation sections.  I have traced
this back to the MakeMaker patch in the src.rpm.  The patch incorrectly sets the
documenation install dir to be INSTALLSITEARCHLIB instead of INSTALLARCHLIB. 
Thus when any perl modules are installed a perllocal.pod file is created in /
rather than INSTALLARCHLIB as it is supposed to be.

Version-Release number of selected component (if applicable):
perl-5.6.1-36.1.99ent

How reproducible:
Always

Steps to Reproduce:
Every one of my 20 machines with ES 2.1 has this problem and any of them that
has had any new perl modules added since the upgrade to this perl rpm no has a
/perllocal.pod

Actual Results:  /perllocal.pod is created

Expected Results:  /usr/lib/perl5/5.6.1/i386-linux/perllocal.pod shoud be created

Additional info:
Comment 1 Jason Witt 2003-10-30 18:42:54 EST
Created attachment 95618 [details]
Patch with correct installation dirs for documentation

This is a fixed patch to replaced the same named one in
perl-5.6.1-36.1.99ent.src.rpm
Comment 2 Jason Vas Dias 2006-04-21 17:05:38 EDT
This bug now appears to be fixed in perl-5.6.1-37.1.99ent - closing out.

Note You need to log in before you can comment on or make changes to this bug.