Bug 10867 - linuxconf generate bad sendmail.cf files
Summary: linuxconf generate bad sendmail.cf files
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: linuxconf
Version: 6.2
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
Assignee: David Lawrence
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-04-17 09:53 UTC by dave heim
Modified: 2008-05-01 15:37 UTC (History)
0 users

(edit)
Clone Of:
(edit)
Last Closed: 2000-05-08 14:18:31 UTC


Attachments (Terms of Use)

Description dave heim 2000-04-17 09:53:44 UTC
I had a problem with sendmail since I used linuxconf to generate it.
The problem is that after, sendmail rejects connection like it :

>Helo host.domain.com
<250 xxxxxxx , pleased to meet you
>Mail from:<>

Then an error occured : 514 buildaddr (no host)

This problem didnt occured before I used linuxconf.

I first submitted this problem to the Sendmail.org Web support that answer
me that my sendmail.cf file was broken.
So I searched the source of this problem, and it seems to be the
/usr/lib/linuxconf/mailconf/rulesets.s0.local.cf which is corrupted since
linuxconf 1.16-10.
Then a replaced it with the rulsets.s0.local.cf of linuxconf 1.16-3 (from
RH 6.1 CDROM), ans all seems to works again.

>Helo host.domain.com
<250 xxxxxxx , pleased to meet you
>Mail from :<>
<Sendm250 <>... Sender ok

So I think that its a linxconf bug !

Comment 1 Trond Eivind Glomsrxd 2001-04-18 20:42:11 UTC
This (sendmail configuration) was removed for the linuxconf version in Red Hat
Linux 7 and newer


Note You need to log in before you can comment on or make changes to this bug.