Bug 108677 - gnome-panel-devel as separate RPM
gnome-panel-devel as separate RPM
Status: CLOSED DUPLICATE of bug 108618
Product: Red Hat Raw Hide
Classification: Retired
Component: gnome-panel (Show other bugs)
1.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mark McLoughlin
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-30 22:08 EST by Michel Alexandre Salim
Modified: 2007-04-18 12:58 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:59:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michel Alexandre Salim 2003-10-30 22:08:27 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20031007
Firebird/0.7 StumbleUpon/1.89

Description of problem:
gnome-panel currently includes header and pkgconfig files, which should really
go into a separate -devel package.

Worse, since it is not a -devel package (despite containing -devel type files)
yum/apt-get'ing gnome-panel does not pull in dependencies required to compile a
program that depends on gnome-panel(-devel).

Is there a long-term plan to split gnome-panel, and if so could gnome-panel be
made to Provides: gnome-panel-devel for the time being?

Referencing a Fedora bug report where this is discussed:
https://bugzilla.fedora.us/show_bug.cgi?id=287

Version-Release number of selected component (if applicable):
gnome-panel-2.4.0-3

How reproducible:
Always

Steps to Reproduce:
1. Remove all GNOME -devel packages
2. yum install gnome-panel and package's -devel dependencies
3. Try and compile something that depends on gnome-panel(-devel) 
    

Actual Results:  Package won't compile due to missing dependencies unless it
BuildRequires itself on gnome-panel(-devel)'s dependencies

Expected Results:  Package should not need to include gnome-panel-devel's
Requires: deps.

Additional info:
Comment 1 Leonard den Ottolander 2004-02-13 14:05:22 EST
This is a DUPLICATE of bug #108618.
Comment 2 Miloslav Trmac 2004-02-18 10:48:55 EST

*** This bug has been marked as a duplicate of 108618 ***
Comment 3 Red Hat Bugzilla 2006-02-21 13:59:35 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.