Bug 108684 - IBM JRE doesn't ever stop running when used as plugin for Moz.
IBM JRE doesn't ever stop running when used as plugin for Moz.
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: IBMJava2-JRE (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Lillian Angel
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-30 23:31 EST by Ali-Reza Anghaie
Modified: 2008-07-13 23:33 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-03-04 23:04:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ali-Reza Anghaie 2003-10-30 23:31:52 EST
Description of problem:

Once you link the gcc3 version of libjavaplugin_oji.so in
/usr/lib/mozilla-1.4/plugins Java plugins work. But once java loads, it never
goes away. If you kill it (even -15), Mozilla dies....

Version-Release number of selected component (if applicable):

IBMJava2-JRE-1.4.1-8
mozilla-1.4-3.0.18

How reproducible:

Always.

Steps to Reproduce:
1. cd /usr/lib/mozilla-1.4/plugins
2. ln -s > /opt/IBMJava2-141/jre/bin/libjavaplugin_ojigcc3.so libjavaplugin_oji.so
3. Start Moz.
4. Goto any site w/ a Java plug.
5. Leave site forever.
6. ps -ef |grep java
7. kill -15 java_pid
etc.
    
Actual results:

Java stay running and when killed it kills Moz.

Expected results:

I'd expect it to have some timeout in Moz. (like Konq.) for when the Java
interpreter should be shutdown if it doesn't itself.

Additional info:
Comment 1 Ali-Reza Anghaie 2003-11-04 07:07:47 EST
One more thing. If you let it run, it doesn't really eat up anymore
resources (other than the memory it already holds), it doesn't chew up
CPU. BUT it doesn't let anything else run either without a reload of
the page w/ the new applet.
Comment 2 Thomas Fitzsimmons 2003-11-04 16:57:45 EST
The Java process stays running in the background so that the
performance penalty associated with JVM startup is incurred only once
per browser run.  Otherwise the JVM would need to be restarted every
time a page containing an applet were loaded or reloaded.

What do you mean by "doesn't let anything else run"?  Can you describe
a scenario in which you've seen this behaviour?
Comment 3 Ali-Reza Anghaie 2003-11-04 18:22:45 EST
Ok, I guess I'm used to Konq's behavior of killing the java process.

On the latter case. During a fresh session goto a java applet page.
Leave that page and go to any other, the new one says it's running in
the Moz. status bar but isn't. You have to hit reload at which point
it really starts running. See what I mean? Cheers, -Ali
Comment 4 Ali-Reza Anghaie 2004-03-04 23:04:27 EST
Somewhere along the way the problem was fixed or wasn't a core
problem. It's working clear-as-day now. Closing bug.

Note You need to log in before you can comment on or make changes to this bug.