Bug 10870 - Network Load Locks Laptop
Network Load Locks Laptop
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
6.2
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Michael K. Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-04-17 09:52 EDT by Red Hat Bugzilla
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-12-14 17:46:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Red Hat Bugzilla 2000-04-17 09:52:46 EDT
Under heavy network load my laptop (thinkpad 600x) with a Xircom realport
PCMCIA card will appear to lock up. The machine stops responding to
keyboard and mouse. However, the machine is still visable on the network,
tested using tcpdump. Physically ejecting the card and re-inserting causes
the machine to resume functioning immediately even processing keystrokes
pressed during the delays.
Comment 1 Red Hat Bugzilla 2000-04-17 10:43:59 EDT
Hmm, doing 'scp <big pile of files> /dev/null' seems to work
OK here.

<tangent>
Is your serial port working?
</tangent>
Comment 2 Red Hat Bugzilla 2000-04-22 01:28:59 EDT
This sounds like an interrupt loop, like the xircom driver is unable to satisfy
some kind of interrupt on the card and is looping forever in the interrupt.
This will typically allow other interrupts to be received but not for higher
level processing to occur.  Once you eject the card, then the interrupt source
is gone and normal processing resumes.  I'm unable to reproduce the issue
because all of my Xircom ethernet cards are Cardbus, while your's is pcmcia
unless you just left the little Cardbus detail off ;-)
Comment 3 Red Hat Bugzilla 2000-08-08 16:55:34 EDT
Does Pinstripe 6.9.5 fix this with the pcmcia update
Comment 4 Red Hat Bugzilla 2002-12-14 17:46:13 EST
Closed - no answer in 2 years

Note You need to log in before you can comment on or make changes to this bug.