Bug 108704 - /etc/pam.d/redhat-config-httpd missing when upgrading
Summary: /etc/pam.d/redhat-config-httpd missing when upgrading
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: redhat-config-httpd   
(Show other bugs)
Version: 1.0
Hardware: All Linux
low
low
Target Milestone: ---
Assignee: Phil Knirsch
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-10-31 12:13 UTC by Axel Thimm
Modified: 2015-03-05 01:13 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-10-31 13:31:50 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Axel Thimm 2003-10-31 12:13:16 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1) Gecko/20031027

Description of problem:
In previous packages /etc/pam.d/redhat-config-httpd was a symlink to apacheconf.

Upgrading the package resulted in apacheconf's removal, but the symlink was left
dangling. Instead a /etc/pam.d/redhat-config-httpd.rpmnew was created.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Upgrade from a previous rawhide/redhat version
2.
3.
    

Additional info:

The %pre script should probably check for the existence of a symlinked 
/etc/pam.d/redhat-config-httpd and move it to
/etc/pam.d/redhat-config-httpd.rpmsave.

Comment 1 Phil Knirsch 2003-10-31 13:31:50 UTC
From which version did you upgrade? When i upgraded the latest Fedora Core
version to 1.1.0-5 it worked fine...

But i agree, will put that check in. Will be in one of the next builds.

Read ya, Phil


Note You need to log in before you can comment on or make changes to this bug.