Bug 108707 - KDE apps shown in english in the menu
KDE apps shown in english in the menu
Product: Fedora
Classification: Fedora
Component: gnome-desktop (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mark McLoughlin
Depends On:
  Show dependency treegraph
Reported: 2003-10-31 08:19 EST by Kjartan Maraas
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2005-02-02 09:02:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Kjartan Maraas 2003-10-31 08:19:49 EST
Description of problem:

It seems that all KDE apps show up in gnome-panel menus in english. The KDE
.desktop files use nb_NO as their locale and that could be part of the problem.
Not sure if adding nb_NO.UTF-8 to SUPPORTED in /etc/i18n/sysconfig will help
since the nb_NO locale is missing from glibc still. They also have no tooltips,
but that's just because there's no Comment=... line in the .desktop files.

Could this be related to http://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=83276 ?

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
Actual results:

Expected results:

Additional info:
Comment 1 Mark McLoughlin 2004-02-20 10:21:51 EST
Yuck, moving to gnome-desktop.

Kjartan: could you summarise the outcome of bug #83276 to help me
figure out what to do about this one ...
Comment 2 Mark McLoughlin 2004-04-22 10:19:41 EDT
Kjartan, could you give us an update ?
Comment 3 Kjartan Maraas 2004-04-22 14:39:55 EDT
The KDE apps in the menu are still in english because the default
locale for Norwegian is no_NO and they are using the new nb_NO locale.
So, all KDE apps use $prefix/share/locale/nb/LC_MESSAGES to look up
their translations and the rest uses $prefix/share/locale/no/LC_MESSAGES

Maybe nb_NO could be added as a fallback domain for translation lookup
while we migrate the existing no_NO translations over to nb_NO?
Comment 4 Kjartan Maraas 2005-02-02 09:02:28 EST
This seems to be working after the move to use nb_NO as the default
locale. Closing.

Note You need to log in before you can comment on or make changes to this bug.