Bug 108707 - KDE apps shown in english in the menu
Summary: KDE apps shown in english in the menu
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-desktop   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Mark McLoughlin
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-10-31 13:19 UTC by Kjartan Maraas
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-02 14:02:28 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Kjartan Maraas 2003-10-31 13:19:49 UTC
Description of problem:

It seems that all KDE apps show up in gnome-panel menus in english. The KDE
.desktop files use nb_NO as their locale and that could be part of the problem.
Not sure if adding nb_NO.UTF-8 to SUPPORTED in /etc/i18n/sysconfig will help
since the nb_NO locale is missing from glibc still. They also have no tooltips,
but that's just because there's no Comment=... line in the .desktop files.

Could this be related to http://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=83276 ?

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
    
Actual results:


Expected results:


Additional info:

Comment 1 Mark McLoughlin 2004-02-20 15:21:51 UTC
Yuck, moving to gnome-desktop.

Kjartan: could you summarise the outcome of bug #83276 to help me
figure out what to do about this one ...

Comment 2 Mark McLoughlin 2004-04-22 14:19:41 UTC
Kjartan, could you give us an update ?

Comment 3 Kjartan Maraas 2004-04-22 18:39:55 UTC
The KDE apps in the menu are still in english because the default
locale for Norwegian is no_NO and they are using the new nb_NO locale.
So, all KDE apps use $prefix/share/locale/nb/LC_MESSAGES to look up
their translations and the rest uses $prefix/share/locale/no/LC_MESSAGES

Maybe nb_NO could be added as a fallback domain for translation lookup
while we migrate the existing no_NO translations over to nb_NO?

Comment 4 Kjartan Maraas 2005-02-02 14:02:28 UTC
This seems to be working after the move to use nb_NO as the default
locale. Closing.


Note You need to log in before you can comment on or make changes to this bug.