Bug 1087115 - Exec format error on init scripts
Summary: Exec format error on init scripts
Status: CLOSED DUPLICATE of bug 851527
Alias: None
Product: Fedora
Classification: Fedora
Component: sks
Version: 20
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
Assignee: Nick Bebout
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-04-14 02:48 UTC by David Benfell
Modified: 2014-08-12 02:14 UTC (History)
1 user (show)

(edit)
Clone Of:
(edit)
Last Closed: 2014-08-12 02:14:45 UTC


Attachments (Terms of Use)

Description David Benfell 2014-04-14 02:48:40 UTC
Description of problem: Exec format error


Version-Release number of selected component (if applicable): 1.1.4-2.fc20


How reproducible: 100%


Steps to Reproduce:
1. systemctl start sks-db (or sks-recon)
2.
3.

Actual results:

[root@munich]~# systemctl start sks-db sks-recon
Job for sks-db.service failed. See 'systemctl status sks-db.service' and 'journalctl -xn' for details.
Job for sks-recon.service failed. See 'systemctl status sks-recon.service' and 'journalctl -xn' for details.
[root@munich]~# systemctl status sks-db.service sks-recon.service ; journalctl -xn
sks-db.service - SYSV: SKS is the OpenPGP Synchronizing Key Server.
   Loaded: loaded (/etc/rc.d/init.d/sks-db)
   Active: failed (Result: exit-code) since Mon 2014-04-14 00:45:58 CEST; 1min 23s ago
  Process: 21395 ExecStart=/etc/rc.d/init.d/sks-db start (code=exited, status=203/EXEC)
 
Apr 14 00:45:58 munich.parts-unknown.org systemd[1]: sks-db.service: control process exited, code=exited status=203
Apr 14 00:45:58 munich.parts-unknown.org systemd[1]: Failed to start SYSV: SKS is the OpenPGP Synchronizing Key Server..
Apr 14 00:45:58 munich.parts-unknown.org systemd[1]: Unit sks-db.service entered failed state.
 
sks-recon.service - SYSV: SKS is the OpenPGP Synchronizing Key Server.
   Loaded: loaded (/etc/rc.d/init.d/sks-recon)
   Active: failed (Result: exit-code) since Mon 2014-04-14 00:45:58 CEST; 1min 23s ago
  Process: 21397 ExecStart=/etc/rc.d/init.d/sks-recon start (code=exited, status=203/EXEC)
 
Apr 14 00:45:58 munich.parts-unknown.org systemd[1]: Starting SYSV: SKS is the OpenPGP Synchronizing Key Server....
Apr 14 00:45:58 munich.parts-unknown.org systemd[21397]: Failed at step EXEC spawning /etc/rc.d/init.d/sks-recon: Exec format error
Apr 14 00:45:58 munich.parts-unknown.org systemd[1]: sks-recon.service: control process exited, code=exited status=203
Apr 14 00:45:58 munich.parts-unknown.org systemd[1]: Failed to start SYSV: SKS is the OpenPGP Synchronizing Key Server..
Apr 14 00:45:58 munich.parts-unknown.org systemd[1]: Unit sks-recon.service entered failed state.
-- Logs begin at Fri 2014-04-11 19:33:17 CEST, end at Mon 2014-04-14 00:46:36 CEST. --
Apr 14 00:45:58 munich.parts-unknown.org systemd[1]: sks-db.service: control process exited, code=exited status=203
Apr 14 00:45:58 munich.parts-unknown.org systemd[1]: Failed to start SYSV: SKS is the OpenPGP Synchronizing Key Server..
-- Subject: Unit sks-db.service has failed
-- Defined-By: systemd
-- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel
--
-- Unit sks-db.service has failed.
--
-- The result is failed.
Apr 14 00:45:58 munich.parts-unknown.org systemd[1]: Unit sks-db.service entered failed state.
Apr 14 00:45:58 munich.parts-unknown.org systemd[1]: Starting SYSV: SKS is the OpenPGP Synchronizing Key Server....
-- Subject: Unit sks-recon.service has begun with start-up
-- Defined-By: systemd
-- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel
--
-- Unit sks-recon.service has begun starting up.
Apr 14 00:45:58 munich.parts-unknown.org systemd[21397]: Failed at step EXEC spawning /etc/rc.d/init.d/sks-recon: Exec format error
-- Subject: Process /etc/rc.d/init.d/sks-recon could not be executed
-- Defined-By: systemd
-- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel
--
-- The process /etc/rc.d/init.d/sks-recon could not be executed and failed.
--
-- The error number returned while executing this process is 8.
Apr 14 00:45:58 munich.parts-unknown.org systemd[1]: sks-recon.service: control process exited, code=exited status=203
Apr 14 00:45:58 munich.parts-unknown.org systemd[1]: Failed to start SYSV: SKS is the OpenPGP Synchronizing Key Server..
-- Subject: Unit sks-recon.service has failed


Expected results: It should start the services.


Additional info: The all-important phrase in this verbiage was "Exec format error". Examining the init scripts, I discovered that there were spaces in front of #!/bin/bash . Removing those spaces solves the problem.

Comment 1 Nick Bebout 2014-08-12 02:14:45 UTC

*** This bug has been marked as a duplicate of bug 851527 ***


Note You need to log in before you can comment on or make changes to this bug.