Bug 108718 - Trying to log off crashes X
Trying to log off crashes X
Status: CLOSED CURRENTRELEASE
Product: Red Hat Raw Hide
Classification: Retired
Component: gnome-session (Show other bugs)
1.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-31 10:10 EST by Daniel Malmgren
Modified: 2007-04-18 12:59 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-03 09:38:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Malmgren 2003-10-31 10:10:06 EST
Description of problem:
When I choose to log out from Gnome and expect to get the confirmation
requester (the one with choices to reboot or shutdown the computer), gnome
instead seems to crash X entirely (which in my case makes init respawn X
and I'm back to the gdm greeter).

Version-Release number of selected component (if applicable):
gnome-session-2.4.0-1
I'm running latest (i386 precompiled) Rawhide versions of all XFree86 and
gnome packages.

How reproducible:
100%

Steps to Reproduce:
1. Choose to log out either from main menu or from a log out button on my panel
    
Actual results:
A confirmation requester with choices to logout/reboot/poweroff

Expected results:
X crashes

Additional info:
The really strange with this is that it only happens if I have a second
screen configured in XF86Config and they screens are not in xinerama mode
(that is, I have one monitor at :0.0 and one at :0.1). I fail to see the
connection here, but I've tried quite some times and this is the case. Maybe the
fancy logout effect can't handle multiple screens?

I get the following in my .xsession-errors:

The program 'gnome-session' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadMatch (invalid parameter attributes)'.
  (Details: serial 1471 error_code 8 request_code 1 minor_code 0)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)
Comment 1 Tristan McCann 2003-11-08 09:54:49 EST
I have a dual-display as well, two distinct displays on one video
card, and I get the same symptoms and the same error when I try to log
out.  I am running Fedora Core 1.
Comment 2 Daniel Malmgren 2004-04-30 11:00:35 EDT
It has come to my knowledge that this is a bug in gnome-session that's
been fixed for 2.6.1. I guess I'll wait with closing it though 'til
2.6.1 is part of Fedora.
Comment 3 Daniel Malmgren 2004-08-03 09:38:19 EDT
Closing this one since 2.7.4, which has this bug fixed, is now used in
devel

Note You need to log in before you can comment on or make changes to this bug.