Bug 108730 - fontconfig man pages broken
fontconfig man pages broken
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: fontconfig (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Owen Taylor
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-31 11:57 EST by Ralf Ertzinger
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-02 15:00:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ralf Ertzinger 2003-10-31 11:57:02 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1) Gecko/20031027

Description of problem:
When trying to view the man page of the fc-cache and fc-list commands, man dies
with an error message:

[sun@nausicaa ~ (0) 33]$ man fc-cache
iconv: illegal input sequence at position 121


Version-Release number of selected component (if applicable):
fontconfig-2.2.1-6.1

How reproducible:
Always

Steps to Reproduce:
1. man fc-cache
2.
3.
    

Actual Results:  An error message appears

Expected Results:  The man page

Additional info:
Comment 1 Peter van Egdom 2004-04-06 11:05:40 EDT
Doing "man fc-cache" in a Fedora Core release 1.91 (FC2) results in :

  XXX
  XXX WARNING: old character encoding and/or character set
  XXX
    <snip> --- the rest of the manpage of "fc-cache" --- <snip>


Relevant packages in Fedora Core release 1.91 (FC2) :
 - "fontconfig-2.2.1-8.1"
 - "man-1.5m2-3"

This bug appears to caused by some encoding errors in the manpages of
the fontconfig package and might be 'fixed' by using a newer version
of the man package.

It seems the encoding errors are still present in the new fontconfig
package but the newer "man" command seems to use a workaround.
Comment 2 Owen Taylor 2004-09-02 15:00:48 EDT
Fixed in 2.2.3-1

* Tue Aug  3 2004 Owen Taylor <otaylor@redhat.com> - 2.2.3-1
- Convert man pages to UTF-8 (#108730, Peter van Egdom)

Note You need to log in before you can comment on or make changes to this bug.