Bug 108737 - RHN does not show that there are updates available in Fedora
RHN does not show that there are updates available in Fedora
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: rhn-applet (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Veillard
:
: 109250 109930 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-31 13:58 EST by Jaap Haitsma
Modified: 2007-11-30 17:10 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-11-14 12:31:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jaap Haitsma 2003-10-31 13:58:18 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20031007
Firebird/0.7

Description of problem:
It seems that the rhn-applet does not handle redirection well.

See mailing list thread:
http://www.redhat.com/archives/fedora-test-list/2003-October/msg03962.html

Version-Release number of selected component (if applicable):
rhn-applet-2.1.2-1

How reproducible:
Always

Steps to Reproduce:
1. Run rhn-applet when there are updates
2. rhn-applet does not show updates
3. When launching up2date it says that there are updates
    

Additional info:
Comment 1 Jay Turner 2003-11-05 21:57:07 EST
*** Bug 109250 has been marked as a duplicate of this bug. ***
Comment 2 William Hooper 2003-11-12 21:29:47 EST
It appears rhn-applet doesn't like the redirects?  If you change it to
the below (comment out originals and replace with the URLs they are
redirected to) it seems to work:

#yum fedora-core-1 http://fedora.redhat.com/releases/fedora-core-1
yum fedora-core-1
http://download.fedora.redhat.com/pub/fedora/linux/core/1/i386/os
#yum updates-released
http://fedora.redhat.com/updates/released/fedora-core-1
yum updates-released
http://download.fedora.redhat.com/pub/fedora/linux/core/updates/1/i386
#yum updates-testing
http://fedora.redhat.com/updates/testing/fedora-core-1
Comment 3 Daniel Veillard 2003-11-13 08:02:54 EST
Yeah, we added redirect support to rhnlib which the applet uses
for Yum HTTP support, unfortunately the rhnlib API used by the
applet are not the ones handling redirection :-\
I need to fix this either at the rhnlib level or at the applet level.

Daniel
Comment 4 Daniel Veillard 2003-11-13 18:11:26 EST
*** Bug 109930 has been marked as a duplicate of this bug. ***
Comment 5 Daniel Veillard 2003-11-14 12:31:40 EST
Version 2.1.4 should fix the redirect support and add file:/// 
support, check:

http://people.redhat.com/~veillard/testing/FC1/i386/rhn-applet/2.1.4/

it has been pushed to rawhide,

Daniel
Comment 6 Gene Czarcinski 2003-11-14 15:33:50 EST
Should not this update be posted to up2dates/testing rather than
rawhide (development)?
Comment 7 Gene Czarcinski 2003-11-14 15:36:20 EST
Works nice.  I also see that you have "fixed" the business about RHN
registering on Fedora Core.

Note You need to log in before you can comment on or make changes to this bug.