This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 108763 - "tc qdisc del dev eth0 root" gives en error
"tc qdisc del dev eth0 root" gives en error
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: iproute (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Phil Knirsch
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-01 04:17 EST by Pawel Orzechowski
Modified: 2015-03-04 20:13 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-21 10:16:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Pawel Orzechowski 2003-11-01 04:17:38 EST
Description of problem: 
Command ""tc qdisc del dev eth0 root" gives an following error:
RTNETLINK answers: No such file or directory

Version-Release number of selected component (if applicable):
iproute-2.4.7-7

How reproducible:
always

Steps to Reproduce:
1. insert "alias eth0 ne" into /etc/modules.conf
2. give an ip number to eth0
3. try: tc qdisc del dev eth0 root
  
Actual results:
RTNETLINK answers: No such file or directory


Expected results:
it should result in no error

Additional info:
I'm trying to configure cbq on my redhat 9 machine. My configuration 
in /etc/sysconfig/cbq/cbq-0004.eth_out is:
DEVICE=eth0,10Mbit,1Mbit
RATE=16Kbit
WEIGHT=4Kbit
PRIO=5
RULE=10.47.0.0/24,
after I ran "cbq start" it gave me a list of errors:
RTNETLINK answers: No such file or directory
RTNETLINK answers: No such file or directory
RTNETLINK answers: No such file or directory
After inspecting a debug info I have discovered that this error comes 
from command "tc qdisc del dev eth0 root"
On the second interface eth1 which is 3c59x, I can run "tc qdisc del 
dev eth0 root" without error.
Comment 1 Jacek Pliszka 2003-12-31 05:23:44 EST
Looks like again HTB support is missing in iproute.
I tried the 2.4.7-9 for Red Hat beta severn and it works fine. Please
release 2.4.7-9 as an update.

Note You need to log in before you can comment on or make changes to this bug.