Bug 108768 - gcc-c++-3.3.2-1 segfault in configure script in qt/kde program compile
gcc-c++-3.3.2-1 segfault in configure script in qt/kde program compile
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: gcc (Show other bugs)
rawhide
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-01 08:58 EST by Eirik Thorsnes
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-11-03 12:13:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Preprocessed source code that segfaults (160.04 KB, application/x-gzip)
2003-11-01 09:01 EST, Eirik Thorsnes
no flags Details
Another preprocessed code that segfaults (from k3b 0.10.1) (53.92 KB, text/plain)
2003-11-02 14:24 EST, Eirik Thorsnes
no flags Details

  None (edit)
Description Eirik Thorsnes 2003-11-01 08:58:23 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1)
Gecko/20031027

Description of problem:
During ./configure script of a c++ program (f.ex. kvirc cvs) g++
segfaults during compile of qt/kde test code. Rename of g++296 to g++
result in NO segfault (but fails to compile).

Output from config.log:

WITH g++3.3.2-1:
------------------
configure:19462: checking if we can compile an X-Qt-KDE application
configure:19504: g++ -o conftest -O2 -Wall  -I/usr/X11R6/include
-I/usr/lib/qt-3.1/./include -I/usr/include/kde   -I/usr/X11R6/include
-s  conftest.cc -L/us
r/lib -L/usr/X11R6/lib -L/usr/lib/qt-3.1/./lib    -L/usr/X11R6/lib 
-lkdecore -lqt-mt  -lXext -lX11 -Wl,-rpath /usr/lib -ldl >&5
In file included from /usr/include/c++/3.3.2/memory:54,
                 from /usr/include/c++/3.3.2/string:48,
                 from /usr/lib/qt-3.1/include/qstring.h:46,
                 from /usr/lib/qt-3.1/include/qwindowdefs.h:44,
                 from /usr/lib/qt-3.1/include/qwidget.h:42,
                 from /usr/lib/qt-3.1/include/qdesktopwidget.h:40,
                 from /usr/lib/qt-3.1/include/qapplication.h:42,
                 from /usr/include/kde/kapplication.h:39,
                 from /usr/include/kde/kapp.h:5,
                 from configure:19524:
/usr/include/c++/3.3.2/bits/stl_algobase.h: In static member function
`static
   _Tp* std::__copy_backward_dispatch<const _Tp*, _Tp*,
   __true_type>::copy(const _Tp*, const _Tp*, _Tp*)':
/usr/include/c++/3.3.2/bits/stl_algobase.h:417: internal compiler
error: Segmentation
   fault


WITH g++296:
------------------
configure:19462: checking if we can compile an X-Qt-KDE application
configure:19504: g++ -o conftest -O2 -Wall  -I/usr/X11R6/include
-I/usr/lib/qt-3.1/./include -I/usr/include/kde   -I/usr/X11R6/include
-s  conftest.cc -L/us
r/lib -L/usr/X11R6/lib -L/usr/lib/qt-3.1/./lib    -L/usr/X11R6/lib 
-lkdecore -lqt-mt  -lXext -lX11 -Wl,-rpath /usr/lib -ldl >&5
/tmp/ccLOYZrr.o(.text+0xc): In function `main':
: undefined reference to `KWin::currentDesktop(void)'
/tmp/ccLOYZrr.o(.text+0x32): In function `main':
: undefined reference to `QCString::QCString(char const *)'
/tmp/ccLOYZrr.o(.text+0x4b): In function `main':
: undefined reference to `KApplication::KApplication(int &, char **,
QCString const &, bool, bool)'
/tmp/ccLOYZrr.o(.text+0x56): In function `main':
: undefined reference to `QCString::~QCString(void)'
/tmp/ccLOYZrr.o(.text+0x60): In function `main':
: undefined reference to `KApplication::~KApplication(void)'
/tmp/ccLOYZrr.o(.text+0x79): In function `main':
: undefined reference to `QCString::~QCString(void)'
collect2: ld returned 1 exit status
configure:19507: $? = 1
configure: failed program was:
| #line 19481 "configure"
| /* confdefs.h.  */
|
| #define PACKAGE_NAME ""
| #define PACKAGE_TARNAME ""
| #define PACKAGE_VERSION ""
| #define PACKAGE_STRING ""
| #define PACKAGE_BUGREPORT ""
| #define PACKAGE "kvirc"
| #define VERSION "3.0.0-beta3"
| #define STDC_HEADERS 1
| #define HAVE_SYS_TYPES_H 1
| #define HAVE_SYS_STAT_H 1
| #define HAVE_STDLIB_H 1
| #define HAVE_STRING_H 1
| #define HAVE_MEMORY_H 1
| #define HAVE_STRINGS_H 1
| #define HAVE_INTTYPES_H 1
| #define HAVE_STDINT_H 1
| #define HAVE_UNISTD_H 1
| #ifdef __cplusplus
| #include <stdlib.h>
| #endif
| #define HAVE_LINUX_SOUNDCARD_H 1
| #define HAVE_SYS_SOUNDCARD_H 1
| #define COMPILE_OSS_SUPPORT 1
| #define HAVE_STRERROR 1
| #define HAVE_INET_NTOA 1
| #define HAVE_INET_ATON 1
| #define HAVE_GETNAMEINFO 1
| #define COMPILE_GET_INTERFACE_ADDRESS 1
| #define COMPILE_USE_DYNAMIC_LABELS 1
| #define COMPILE_WITH_SYSTEM_MEMMOVE 1
| #define AVERAGE_CHANNEL_USERS 349
| #define COMPILE_SPLASH_SCREEN 1
| #define COMPILE_INFO_TIPS 1
| #define COMPILE_SCRIPTTOOLBAR 1
| #define COMPILE_CRYPT_SUPPORT 1
| #define COMPILE_USE_AA_FONTS 1
| #define COMPILE_USE_GSM 1
| #define COMPILE_PSEUDO_TRANSPARENCY 1
| #define COMPILE_THREADS_USE_POSIX 1
| /* end confdefs.h.  */
|
|                               #include "kapp.h"
|                               #include "kwin.h"
|
| int
| main ()
| {
|
|                               int a = KWin::currentDesktop();
|                               KApplication app(a,0,"kvirc");
|
|   ;
|   return 0;
| }
configure:19525: result: failed
configure:19527: error: This was a fatal one...aborting


Version-Release number of selected component (if applicable):
gcc-c++-3.3.2-1

How reproducible:
Always

Steps to Reproduce:
1. Run configure script of program testing qt/kde compile with g++
2. Read config.log
    

Actual Results:  Segfault

Expected Results:  Should compile test code without segfault
Comment 1 Eirik Thorsnes 2003-11-01 09:01:36 EST
Created attachment 95646 [details]
Preprocessed source code that segfaults
Comment 2 Eirik Thorsnes 2003-11-02 14:24:08 EST
Created attachment 95667 [details]
Another preprocessed code that segfaults (from k3b 0.10.1)

configure:20570: checking if C++ programs can be compiled
configure:20600: g++ -c -Wnon-virtual-dtor -Wno-long-long -Wundef -Wall -W
-Wpointer-arith -Wwrite-strings -ansi -D_XOPEN_SOURCE=500 -D_BSD_SOURCE
-Wcast-al
ign -Wconversion -Wchar-subscripts -O2 -O2 -g -pipe -march=i386 -mcpu=i686
-Wformat-security -Wmissing-format-attribute  -fno-check-new -fno-common 
conftes
t.cc >&5
In file included from /usr/include/c++/3.3.2/memory:54,
		 from /usr/include/c++/3.3.2/string:48,
		 from conftest.cc:28:
/usr/include/c++/3.3.2/bits/stl_algobase.h: In static member function `static
   _Tp* std::__copy_backward_dispatch<const _Tp*, _Tp*,
   __true_type>::copy(const _Tp*, const _Tp*, _Tp*)':
/usr/include/c++/3.3.2/bits/stl_algobase.h:417: internal compiler error:
Segmentation
   fault
Comment 3 Jakub Jelinek 2003-11-03 12:13:56 EST
I cannot reproduce either of these segfaults with gcc-c++-3.3.2-1, sorry.
Both preprocessed testcases compile just fine with the given options.
Comment 4 Eirik Thorsnes 2003-11-04 17:31:17 EST
For the record:
After change of memory (and a force re-install of gcc rpm), it now
works for me too.

Note You need to log in before you can comment on or make changes to this bug.