Bug 108776 - rpm -qf /usr/share/icons segfaults
rpm -qf /usr/share/icons segfaults
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
9
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-01 16:23 EST by Ville Skyttä
Modified: 2007-04-18 12:59 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-12-26 13:31:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
gdb backtrace of "rpm -qf /usr/share/icons" segfault (2.49 KB, text/plain)
2003-11-01 16:25 EST, Ville Skyttä
no flags Details

  None (edit)
Description Ville Skyttä 2003-11-01 16:23:49 EST
RHL 9, rpm-4.2-1 installed from
http://download.fedora.us/patches/redhat/9/i386/RPMS.stable/

"rpm -qf /usr/share/icons" segfaults.  Will attach a gdb backtrace in
case it's useful.
Comment 1 Ville Skyttä 2003-11-01 16:25:05 EST
Created attachment 95651 [details]
gdb backtrace of "rpm -qf /usr/share/icons" segfault
Comment 2 Jeff Johnson 2003-12-26 13:31:54 EST
No reproduce, probably rpmdb data related like most rpm
segfaults, or otherwise system peculier:

$ rpm -q rpm rpm-devel rpm-build rpm-python popt
rpm-4.2-1
rpm-devel-4.2-1
rpm-build-4.2-1
rpm-python-4.2-1
popt-1.8-1
$ rpm -qf /usr/share/icons
kdelibs-3.1.94-0.2
system-config-proc-0.24-1
redhat-artwork-0.89-1
Comment 3 Ville Skyttä 2003-12-26 18:54:49 EST
Yah, I cannot reproduce this any more either.  Abouts these kind of
bugs, would you recommend "don't report" or "don't report unless you
can reproduce on multiple boxen" or $other_tips_for_useful_reports?

Note You need to log in before you can comment on or make changes to this bug.