Bug 10878 - NFS mount problems with rh6.1
Summary: NFS mount problems with rh6.1
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: nfs-utils   
(Show other bugs)
Version: 7.0
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Steve Dickson
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-04-17 18:59 UTC by dboyd
Modified: 2007-04-18 16:26 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-08 18:30:24 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description dboyd 2000-04-17 18:59:49 UTC
We have an NFS server, running Redhat Linux 6.1.  We have upgraded a number
of workstations to RedHat Linux 6.2.  The NFS mounted filesystems mount
inconsistently between versions.  The RedHat 6.2 workstations receive a
'permission denied' error when trying to mount the nfs filesystems.  This
did not happen with 6.1 workstations.

The current workaround is to 'exportfs <workstation>:/<dir>' on the server,
every time a 'permission denied' error is found.  After doing so, the
workstation is able to mount the filesystem.  However, the workstation will
not show up in the exportfs list.

This problem is happening in a commercial environment, with a number of
very knowledgable developers being effected.  If you require us to do any
testing, feel free to ask, we will do what we can.

my work email:  dboyd@cal.montage.ca

Comment 1 Cliff Bergman 2000-07-17 21:38:48 UTC
I'm seeing the same behavior on our 6.2 system.  There seems to be a change from
the way
nfs worked in previous versions of RedHat.  I think that what is happening is
this:  If a directory is
exported and if a different partition of a local disk is mounted on a
subdirectory, then that second partition is no longer exported as a
subdirectory.  In old versions of RH, it was exported.



Comment 2 Cristian Gafton 2000-08-09 02:35:41 UTC
assigned to johnsonm

Comment 3 Jim Modecki 2001-03-30 23:46:11 UTC
I have found that the mount command in RH 6.2 will not nfs mount a volume exported from Novell 5.1 NFS.  It gets a permission denied or volume not 
found message.  (It works fine on RH 7.0).  When  I compiled and installed mount-2.10m-6 on RH 6.2,  the problem went away.

Comment 4 Steve Dickson 2003-01-08 18:30:24 UTC
I'm unable to reproduce this in the current release.


Note You need to log in before you can comment on or make changes to this bug.