Bug 108780 - info unusable: wrong permissions on /usr/share/info/dir
info unusable: wrong permissions on /usr/share/info/dir
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: bc (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Thomas Woerner
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-01 17:19 EST by J. J. Ramsey
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-07 10:07:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description J. J. Ramsey 2003-11-01 17:19:05 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1)
Gecko/20031027

Description of problem:
If I type "info ld", I get the error message "info: dir: Permission
denied". This is because only root has permission to read
/usr/share/info/dir. I can fix the problem easily with chmod.


Version-Release number of selected component (if applicable):
info-4.5-2

How reproducible:
Always
Comment 1 J. J. Ramsey 2003-11-01 17:22:36 EST
Due to braindeadness in the new Bugzilla, I was forced to enter a
false value for the component. "info" was not available from the list
of components, and having anything in the "Component Text" box made
Bugzilla tell me to press "Back" and choose a component.
Comment 2 Tim Waugh 2003-11-03 04:20:59 EST
What's the history of this installation?
Comment 3 J. J. Ramsey 2003-11-03 08:17:55 EST
> What's the history of this installation?

Originally test3, updated to the latest Rawhide/Fedora-updates.
Comment 4 Tim Waugh 2003-11-04 11:48:40 EST
What does 'umask' say, as root?
Comment 5 J. J. Ramsey 2003-11-04 12:35:23 EST
> What does 'umask' say, as root?

0022
Comment 6 Tim Waugh 2003-11-04 12:47:59 EST
A fresh installation of Fedora Core (latest tree) doesn't have this
problem.  I think this probably occurred during an upgrade of a
separate package.  It sounds like an errant scriptlet adjusting that
file without using install-info.

One package whose scriptlet looks particularly suspicious is bc. 
Reassigning.
Comment 7 Thomas Woerner 2004-10-07 10:07:50 EDT
Closing as "NOT A BUG".

Note You need to log in before you can comment on or make changes to this bug.