Bug 108820 - openssl headers bug in openssl-devel-0.9.7a-23
openssl headers bug in openssl-devel-0.9.7a-23
Status: CLOSED WONTFIX
Product: Red Hat Raw Hide
Classification: Retired
Component: openssl (Show other bugs)
1.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tomas Mraz
Brian Brock
http://newrpms.sunsite.dk
:
: 108819 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-02 10:48 EST by rudolf kastl
Modified: 2007-04-18 12:59 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-04 11:08:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description rudolf kastl 2003-11-02 10:48:16 EST
Description of problem:


Version-Release number of selected component (if applicable):

openssl-0.9.7a-23

How reproducible:

try to rebuild that rpm:
http://newrpms.sunsite.dk/apt/redhat/en/i386/9.0/SRPMS.newrpms/wine-0.20031016-2.src.rpm

Steps to Reproduce:
1. rebuild the above mentioned rpm

or alternatively if your familiar with building wine try the latest
monthly release.
  
Actual results:
gcc32 -c -I. -I. -I../../include -I../../include  -D__WINESRC__
-D_WINX32_ -D_REENTRANT -fPIC -Wall -mpreferred-stack-boundary=2
-fno-strict-aliasing -Wpointer-arith -I/usr/kerberos/include -O2 -g
-pipe -march=i386 -mcpu=i686 -o cookie.o cookie.c
In file included from /usr/include/openssl/ssl.h:179,
                 from internet.h:36,
                 from cookie.c:39:
/usr/include/openssl/kssl.h:136: syntax error before '*' token
/usr/include/openssl/kssl.h:149: syntax error before '*' token
/usr/include/openssl/kssl.h:150: syntax error before '*' token
/usr/include/openssl/kssl.h:151: syntax error before '*' token
/usr/include/openssl/kssl.h:151: syntax error before '*' token
/usr/include/openssl/kssl.h:152: syntax error before '*' token
/usr/include/openssl/kssl.h:153: syntax error before '*' token
/usr/include/openssl/kssl.h:155: syntax error before '*' token
/usr/include/openssl/kssl.h:157: syntax error before '*' token
/usr/include/openssl/kssl.h:159: syntax error before '*' token
/usr/include/openssl/kssl.h:167: syntax error before '*' token
In file included from internet.h:36,
                 from cookie.c:39:
/usr/include/openssl/ssl.h:909: syntax error before "KSSL_CTX"
/usr/include/openssl/ssl.h:931: syntax error before '}' token
make[2]: *** [cookie.o] Error 1
make[2]: Leaving directory `/tmp/rpm/BUILD/wine-20031016/dlls/wininet'
make[1]: *** [wininet] Error 2
make[1]: Leaving directory `/tmp/rpm/BUILD/wine-20031016/dlls'
make: *** [dlls] Error 2


Expected results:

builds fine

Additional info:

both gcc 3.3.2 and gcc32 are affected

----
rudolf kastl
Comment 1 rudolf kastl 2003-11-02 10:55:41 EST
*** Bug 108819 has been marked as a duplicate of this bug. ***
Comment 2 Bill Nottingham 2003-11-02 23:25:41 EST
*** Bug 108819 has been marked as a duplicate of this bug. ***
Comment 3 Tomas Mraz 2005-02-04 11:08:34 EST
This is probably a conflicting #define of FAR with wine.

Note You need to log in before you can comment on or make changes to this bug.