Bug 108845 - keyboard focus with command line applet
keyboard focus with command line applet
Status: CLOSED CURRENTRELEASE
Product: Red Hat Raw Hide
Classification: Retired
Component: gnome-applets (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mark McLoughlin
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-02 13:58 EST by Michael Andrews
Modified: 2007-04-18 12:59 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-07-19 09:34:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Andrews 2003-11-02 13:58:27 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5)
Gecko/20031007 Firebird/0.7

Description of problem:
I cannot type into the command line applet in the gnome panels.  I
have my desktop set to pointer focus (which seems to be the old
'sloppy focus').  When I move the mouse into the command line applet
to type a command, the focus remains with the last application window
the cusor was in and the keystrokes are reported to that application.

Clicking in the command applet does NOT help.

Version-Release number of selected component (if applicable):
2.4.1-1

How reproducible:
Always

Steps to Reproduce:
1. Set focus to pointer (Preferences | Window | click select when
mouse moves over)
2. Add command line applet to panel (right click in panel | Add to
Panel | Utility | Command Line)
3. Move mouse to applet and type something.
    

Actual Results:  Key strokes are 'typed' into the last application
window the cursor was in (the window with the highlighted border).

Expected Results:  The keystrokes should be typed into the command
line applet.

Additional info:

I'm 'synced' with the rawhide directory.
Comment 1 Mark McLoughlin 2004-07-19 09:34:44 EDT
I'm pretty sure this got fixed since - I believe it was a metacity bug.

Note You need to log in before you can comment on or make changes to this bug.