Bug 108924 - Auto-help shows incorrect usage
Auto-help shows incorrect usage
Status: CLOSED DEFERRED
Product: Red Hat Linux
Classification: Retired
Component: popt (Show other bugs)
GinGin64
All Linux
low Severity medium
: ---
: ---
Assigned To: Jeff Johnson
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-03 08:35 EST by Jan Engelhardt
Modified: 2007-03-27 00:11 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-12-30 11:37:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
A patch fixing this visual glitch (362 bytes, patch)
2003-11-03 08:38 EST, Jan Engelhardt
no flags Details | Diff

  None (edit)
Description Jan Engelhardt 2003-11-03 08:35:12 EST
Description of problem:
I have found an ugly cosmetic flaw in popt which can lead to its
improper usage.
I have puzzled for some time what the difference between             
          
   application --someoption -g=sys                                   
          
and                                                                  
          
   application --someoption -g sys             

is. According to the POPT_AUTOHELP (-? flag), the -g= style also works
(besides -g and --group and --group= for example), however, that is
wrong. I really think in the help usage (-?), the = should NOT appear
on single options, like:                                             
                    

   -g=gid       Provide a GID for the new group                      
          

things like                                                          
          

   -g, --group=gid   Provide...                                      
          
   --group=gid       Provide                                         
          

are ok though, since --longopt accepts both whitespace and =.        
          


Additional info:
popt-1.6.4-31 from SuSE, though this issue can be found in any popt.
Comment 1 Jan Engelhardt 2003-11-03 08:38:11 EST
Created attachment 95670 [details]
A patch fixing this visual glitch
Comment 2 Jeff Johnson 2003-12-26 12:53:19 EST
FIxed in CVS, should be in rpm-4.2.2-0.8 and later.
Comment 3 Jan Engelhardt 2003-12-27 06:02:25 EST
There have been more codeplaces that are odd besides the ones corrected in the
first patch. Here is another one to fix other places where this -A=stuff comes
in (if you have not corrected that already yourself)
http://vitalnix.sf.net/popt-fix/popt-1.6.4-hx.diff
 
Comment 4 Jeff Johnson 2003-12-30 11:36:53 EST
Hmmm patch does not apply to popt-1.8.2.

Deffered until I get a chance.

Note You need to log in before you can comment on or make changes to this bug.