Bug 108940 - tons of warnings from rpm --verify with prelink-0.3.0-13
tons of warnings from rpm --verify with prelink-0.3.0-13
Product: Red Hat Raw Hide
Classification: Retired
Component: prelink (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
David Lawrence
Depends On:
  Show dependency treegraph
Reported: 2003-11-03 11:14 EST by Jonathan Kamens
Modified: 2007-04-18 12:59 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-09-03 02:54:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Jonathan Kamens 2003-11-03 11:14:17 EST
I'm getting tons of warnings when I run "rpm --verify -a" after 
installing prelink-0.3.0-13.  For example:

prelink: /usr/lib/libbeecrypt.so.6.1.0: prelinked file was modified
S.?.....   /usr/lib/libbeecrypt.so.6.1.0
prelink: /usr/lib/libgimpprint.so.1.1.0: prelinked file was modified
S.?.....   /usr/lib/libgimpprint.so.1.1.0
prelink: /usr/lib/libwrap.so.0.7.6: prelinked file was modified
S.?.....   /usr/lib/libwrap.so.0.7.6
prelink: /usr/lib/libedsio.so.0.0.0: prelinked file was modified
S.?.....   /usr/lib/libedsio.so.0.0.0
prelink: /usr/lib/libxdelta.so.2.0.0: prelinked file was modified
S.?.....   /usr/lib/libxdelta.so.2.0.0
Comment 1 Jakub Jelinek 2003-11-03 11:59:23 EST
Immediately after upgrade? If so, this is expected.
If you get the same the day after the upgrade (well, after first
/etc/cron.daily/prelink run after the upgrade), then something is
Comment 2 Jonathan Kamens 2003-11-03 12:00:17 EST
I continue to get it after /etc/cron.daily/prelink has run.  I 
confirmed this before filing the bug report.  Sorry I forgot to 
mention it.
Comment 3 Jakub Jelinek 2003-11-04 05:06:31 EST
Have those shared libraries been reprelinked after upgrade to this
prelink?  They certainly should.  Can you:
rpm -qi prelink
prelink -nv /usr/lib/libbeecrypt.so.6.1.0
ls -l /usr/lib/libbeecrypt.so.6.1.0
ls -l --time=ctime /usr/lib/libbeecrypt.so.6.1.0
prelink -p
Comment 4 Jonathan Kamens 2003-11-05 12:54:01 EST
My machine got somewhat trashed, and after reinstalling a bunch of
RPMs as well as uninstalling and reinstalling prelink, I can no longer
duplicate this problem.
Comment 5 Michael Young 2003-11-10 17:16:38 EST
Duplicate of bug 107062 and bug 89953 .
Comment 6 Bill Nottingham 2006-08-07 21:43:55 EDT
'Red Hat Raw Hide' refers to the development tree for Red Hat Linux.
Red Hat Linux is no longer supported by Red Hat, Inc. If you are still
running Red Hat Linux, you are strongly advised to upgrade to a
current Fedora Core release or Red Hat Enterprise Linux or comparable.
Some information on which option may be right for you is available at

Red Hat apologizes that these issues were not resolved in a more
timely manner. However, we do want to make sure that important 
don't slip through the cracks. If these issues are still present
in a current release, such as Fedora Core 5, please move these
bugs to that product and version. Note that any remaining Red Hat
Raw Hide bugs will be closed as 'CANTFIX' on September 30, 2006.
Thanks again for your help.
Comment 7 Jonathan Kamens 2006-09-03 02:54:23 EDT
Can't duplicate any longer.

Note You need to log in before you can comment on or make changes to this bug.