This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 108966 - Images do not show up in published Articles
Images do not show up in published Articles
Status: CLOSED RAWHIDE
Product: Red Hat Enterprise CMS
Classification: Retired
Component: other (Show other bugs)
nightly
All Linux
medium Severity medium
: ---
: ---
Assigned To: Vadim Nasardinov
Jon Orris
:
Depends On:
Blocks: 106597
  Show dependency treegraph
 
Reported: 2003-11-03 16:08 EST by Jon Orris
Modified: 2007-04-18 12:59 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-11-05 11:45:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jon Orris 2003-11-03 16:08:25 EST
Description of problem:
@37632/postgres/resin

Images do not show up in published Articles. Looking at the XML debug
output, it doesn't appear as though the image element  is added.


<bebop:page application="content" class="simplePage" id="itemPage">
<bebop:title>CMS</bebop:title>
<ui:userBanner familyName="Orris" givenName="Jon" greeting="Welcome "
helpLabel="Help " loginURL="/ccm/register/"
logoutURL="/ccm/register/logout/" metadata.tag="top" portalLabel="My
Portal " primaryEmail="jorris@redhat.com" screenName="jorris"
signoutLabel="Sign out " userID="[com.arsdigita.kernel.User:{id=17}]"
workspaceURL="/ccm/pvt/"/>
<ui:siteBanner admin="" hostname="" metadata.tag="bottom" sitename=""/>
-
	<cms:contentPanel id="itemXML">
-
	<cms:item oid="[com.arsdigita.cms.contenttypes.Article:{id=50075}]">
<objectType>com.arsdigita.cms.contenttypes.Article</objectType>
-
	<type oid="[com.arsdigita.cms.ContentType:{id=3003}]">
<label>Article</label>
<description>An article type with image</description>
</type>
<name>fsda</name>
<language>en</language>
<title>fsda</title>
-
	<textAsset oid="[com.arsdigita.cms.TextAsset:{id=50078}]">
<content>sadfsdfafdsafsda</content>
</textAsset>
</cms:item>
</cms:contentPanel>
</bebop:page>
Comment 1 Daniel Berrange 2003-11-05 05:25:00 EST
I'm unable to reproduce this problem. At p4 37696, postgres 7.3, resin
2.1.10.

I created an Article, uploaded an image & previewed it fine. I also
published the article & viewed the corresponding live page. The XML
from the live page is:

<cms:contentPanel id="itemXML">
-
	<cms:item oid="[com.arsdigita.cms.contenttypes.Article:{id=5003}]">
<objectType>com.arsdigita.cms.contenttypes.Article</objectType>
-
	<type oid="[com.arsdigita.cms.ContentType:{id=188}]">
<label>Article</label>
<description>An article type with image</description>
</type>
<name>sdfsdfsdfsd</name>
<language>en</language>
<title>sdfsdfsdfsd</title>
-
	<textAsset oid="[com.arsdigita.cms.TextAsset:{id=5006}]">
<content>

Edit text here</content>
</textAsset>
-
	<imageCaptions
oid="[com.arsdigita.cms.ArticleImageAssociation:{id=5007}]">
<caption>dfsfds</caption>
-
	<imageAsset oid="[com.arsdigita.cms.ReusableImageAsset:{id=5008}]">
<id>5008</id>
-
	<mimeType oid="[com.arsdigita.cms.MimeType:{mimeType=image/jpeg}]">
<mimeType>image/jpeg</mimeType>
<label>JPG image</label>
<fileExtension>jpg</fileExtension>
</mimeType>
</imageAsset>
</imageCaptions>
<lead>Eeek</lead>
</cms:item>
</cms:contentPanel>
Comment 2 Jon Orris 2003-11-05 11:45:02 EST
This error appears to be fixed by 37632 & 37697.

Note You need to log in before you can comment on or make changes to this bug.