Bug 108968 - Published Multi Part Article section links have no effect
Published Multi Part Article section links have no effect
Status: CLOSED RAWHIDE
Product: Red Hat Enterprise CMS
Classification: Retired
Component: content types (Show other bugs)
nightly
All Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Berrange
Jon Orris
:
Depends On:
Blocks: 106597
  Show dependency treegraph
 
Reported: 2003-11-03 16:59 EST by Jon Orris
Modified: 2007-04-18 12:59 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-11-14 09:42:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jon Orris 2003-11-03 16:59:59 EST
Description of problem:
@37632/postgres/resin

Published MPA section links have no effect. Clicking the links doesn't
change the page view, or bring up the particular section. Only the
summary info is displayed
Comment 1 Daniel Berrange 2003-11-03 17:13:01 EST
FYI, the MPA content type requires its own custom JSP to be uploaded
and published. THis JSP is same as the standard item.jsp, but with the
addition of the ArticleSectionPanel bebop component which renders the
currently selected section.
Comment 2 Daniel Berrange 2003-11-05 05:53:57 EST
Previously the CMS SectionInitializer had code which would upload a
JSP template for a content type when mapping it to a section.
Multipart article and the formbuilder types both used this capability
to register a custom template, replacing the standard item.jsp.

For MPA, the template would look like:

<jsp:root xmlns:jsp="http://java.sun.com/JSP/Page"
          xmlns:define="/WEB-INF/bebop-define.tld" 
          xmlns:show="/WEB-INF/bebop-show.tld"
          version="1.2">

  <define:page name="itemPage" application="content" 
    title="CMS" cache="true">

    <define:component name="itemXML"
      classname="com.arsdigita.cms.dispatcher.ContentPanel"/>
    <define:component name="sectionXML"
classname="com.arsdigita.cms.contenttypes.ui.mparticle.ArticleSectionPanel"/>
  </define:page>

  <show:all/>
</jsp:root>


The new loader classes which map the contnet type into /content don't
create this JSP template, so MPA published view is missing the XML
from the ArticleSectionPanel component.

I tried uploading the above template to MPA, but then encountered
another problem.

The CMS template root is '/packages/content-section/templates', but
p2fs is publishing into '/work/templates'. We can't simply change the
CMS template root, since then it won't pick up the default 'item.jsp'
or any other 'default' templates a project may pre-populate. For
exmaple, APLAWS creates a 'subsite-item.jsp' in
/packages/content-section/templates to provide an alternate view for
Virtual Hosted subsites.

Thus, before to resolve this ticket two things need to be done:

1. Add back in code to populate a template for MPA when mapping it to
a content section (or some equivalent solution)
2. Resolve the difference in directory location between CMS & p2fs.
Comment 3 Justin Ross 2003-11-13 03:44:15 EST
Status update:

I have done items one and two, but they're not the real culprit.  I
still don't get any extra output from clicking a section link.  I'm
now thinking it may be a stylesheet issue.

This has been a quizical bug.  Best I can tell and contrary to what
Dan suggests above, neither 5.2 or Troika ever actually used the
default type template registration code they had.  At least I can't
find any configuration we shipped that would have caused us too.  Nor
can I find any JSPs that used ArticleSectionPanel.  Anybody have any
clues for me?

Comment 4 Justin Ross 2003-11-13 15:44:19 EST
Status again:

The real problem was that the proper XML traversal logic was not in
place.  That was fixed in perforce change 37981.

Underneath this, there is another bug: the section links are
incorrect.  They link to /ccm/content/?page=1 instead of
/ccm/content/mympa?page=1.

I'm going to hand this off to Dan at this point, since these bugs have
to do with change 35489, the one that swapped in page factory and item
JSPs for the existing index page and mparticle transforms.  I figure
his familiarity with the code will make him a lot faster at fixing it. 
Comment 5 Daniel Berrange 2003-11-14 06:39:45 EST
The XSL for ArticleSection had not been updated to follow the new
content type standards for styling so was displaying as a pink box.
I also removed the XML traversal rules for 'sections/text' and
'sections/image' against MultiPartArticle, since they were only
required for ArticleSection. From my testing now, MPA is working as
I'd expect it to. This is at p4 38026

I couldn't reproduce the other problem with section links being
incorrect. The link href is generated to be:

   <a href="?page=2">

which according to the rules for procesing relative hyperlinks should
cause the current URL to be reloaded with the new parameter. So i vote
for syncing to tip & sending to QA again.
Comment 6 Jon Orris 2003-11-14 09:42:06 EST
Confirmed that section links now work, and the MPA renders correctly.
There is still an issue with P2FS not publishing it correctly, but
this is not a concern for this release.

Note You need to log in before you can comment on or make changes to this bug.