Bug 108978 - LTC5228-LVM support needed for "vpath" block devices
LTC5228-LVM support needed for "vpath" block devices
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: lvm (Show other bugs)
3.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Stephen Tweedie
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-03 18:37 EST by IBM Bug Proxy
Modified: 2007-11-30 17:06 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-12-15 16:08:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
lvm-sdd-1.0.3.patch (750 bytes, application/octet-stream)
2003-11-03 18:39 EST, IBM Bug Proxy
no flags Details

  None (edit)
Description IBM Bug Proxy 2003-11-03 18:37:21 EST
The following has be reported by IBM LTC:  
LVM support needed for 
Hardware Environment: any

Software Environment: standard RHEL 3 GA install


Steps to Reproduce:
1. install lvm source RPM
2. read source
3.

Actual Results: Source includes a fixed list of block devices which
lvm will
allow for its underlying devices.  There is a patch
lvm-1.0.3-viodasd.patch
which adds and IBM's iSeries driver "viod".  In order to support LVM
on top of
IBM's SDD multipathing driver, we need a similar patch to allow
devices named
"vpath".  A sample patch against LVM 1.0.3 will be attached.

Expected Results: Preferrably LVM would allow any block device instead
of having
a hard coded list of strings that are assumed to be block devices. 
Lacking that
we would like "vpath" to be an allowed string.

Additional Information: We created this patch originally two years ago
and it
works.  Presumably Sistina and the kernel.org kernel would not accept this
patch to support a closed source out-of-kernel driver, so we never
bothered
asking for it.  Now that RedHat is supporting LVM, and is including
patches to
support special IBM block devices, we'd like SDD to be included as
well.Created an attachment (id=1975)
Patch LVM to support "vpath" devices.

Simple LVM patch to allow the string "vpath" to represent a valid
block device.Glen/Greg - please submit this to Red Hat immediately. 
Thanks.
Comment 1 IBM Bug Proxy 2003-11-03 18:39:02 EST
Created attachment 95696 [details]
lvm-sdd-1.0.3.patch
Comment 2 IBM Bug Proxy 2003-11-03 18:40:46 EST
------ Additional Comments From gjlynx@us.ibm.com(prefers email via gjohnson@austin.ibm.com)  2003-03-11 18:40 -------
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=108976 
Comment 3 IBM Bug Proxy 2003-11-03 18:51:01 EST
please disregard last comment
Comment 4 Bob Johnson 2003-12-15 15:35:42 EST
This is a feature request - should come in thru issue tracker.
Not a bug.
Comment 5 IBM Bug Proxy 2003-12-19 17:18:47 EST
------ Additional Comments From tpepper@us.ibm.com(prefers email via lnxninja@us.ibm.com)  2003-12-18 21:13 -------
I really wish I could remember now who told me this had to be in bugzilla... 
Comment 6 IBM Bug Proxy 2004-01-06 10:02:06 EST
------ Additional Comments From khoa@us.ibm.com  2004-01-06 03:50 -------
Tim - this bug and patch should be in LTC Bugzilla.  You did the correct 
thing.  What Bob Johnson at Red Hat requested is that we should enter
this into Red Hat Issue Tracker - which I am sure Mark/Glen would gladly
do so.  Thanks.

Glen/Mark - please submit this to RH Issue Tracker.  Thanks. 
Comment 7 Bob Johnson 2004-01-11 22:01:52 EST
never came in as an issue tracker....
Comment 8 IBM Bug Proxy 2004-01-23 23:46:51 EST
----- Additional Comments From khoa@us.ibm.com  2004-01-23 09:38 -------
Glen/Mark - have you submitted this to RHIT yet ?  If so, please modify
the summary to indicate the RHIT#.  Thanks. 
Comment 9 Bob Johnson 2004-07-30 15:07:37 EDT
Mark Wisner, still open feature ?

Note You need to log in before you can comment on or make changes to this bug.