Bug 109004 - i810_audio lockup using Windows Media Player 6.4 w/crossover plugin/office
i810_audio lockup using Windows Media Player 6.4 w/crossover plugin/office
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel (Show other bugs)
3.0
i386 Linux
low Severity low
: ---
: ---
Assigned To: John W. Linville
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-04 01:42 EST by Chris Kloiber
Modified: 2007-11-30 17:06 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-21 10:55:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
sysreport output (600.58 KB, application/x-bzip2)
2003-11-04 01:44 EST, Chris Kloiber
no flags Details

  None (edit)
Description Chris Kloiber 2003-11-04 01:42:55 EST
Description of problem:

Machines hard lock running Codeweavers Plugin (v2.0.2) or Office
(v2.1.0) when the sound device is used like when launching Window
Media Player 6.4. 

Version-Release number of selected component (if applicable):
kernel-2.4.21-4.0.1.EL

How reproducible:
100%

Steps to Reproduce:
1. Install Crossover Plugin or Office (free trial version available)
2. Install Windows Media Player 6.4
3. Open an avi... and halt!
  
No debugging output on serial console, no VT switching, no magic sysrq
keys function. nmi_watchdog does not function on this system either.

I even tried installing and running ALSA on this system. Sound under
linux became usable (with stock driver sound speed is way off) but
ALSA sound fails with exact same results. (Could it be the hardware
itself?) ALSA has been backed out for further testing.

If you disable sound entirely (remove sound drivers), no lockup
occurs. This should prove it's sound related.

Hardware information for this ssytem (HP/Compaq D530S Workstation)
will be attached in sysreport output, but I have heard other users
experiencing similar problems in taroon-list.
Comment 1 Chris Kloiber 2003-11-04 01:44:27 EST
Created attachment 95701 [details]
sysreport output
Comment 2 Yue Shi Lai 2003-11-12 14:33:15 EST
I cannot reproduce this effect of complete system lockup.

However effectively all plugins installed in Crossover Plugin failes
to play sound except the first seconds.

I was not able to try this with the commercial OSS, in order to
detemine whether it is sound driver-related, since the commercial OSS
fails completely on my ICH4. Thus I cannot comment on whether it is
sould driv er related.
Comment 3 Jeff Garzik 2004-03-03 03:18:18 EST
Does this problem still occur in latest { RHEL3 | Fedora }?
Comment 4 Chris Kloiber 2004-06-27 23:23:34 EDT
I can't say, I no longer have access to the machines I used when this
occurred. I don't have this kind of issue with my current
hardware/updated Codeweavers Offerings (Plugin having been discontinued) 

I think you could close this if you like.
Comment 5 John W. Linville 2005-02-21 10:55:04 EST
Closed based on above feedback...please re-open if problem is still
observed on current Red Hat distros...

Note You need to log in before you can comment on or make changes to this bug.