Bug 10901 - Sparc installation crashes when installing glibc
Summary: Sparc installation crashes when installing glibc
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda   
(Show other bugs)
Version: 6.2
Hardware: sparc
OS: Linux
low
high
Target Milestone: ---
Assignee: Michael Fulbright
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-04-18 18:59 UTC by Geoff Reedy
Modified: 2008-05-01 15:37 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-09-14 16:34:49 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Geoff Reedy 2000-04-18 18:59:05 UTC
The Sparc installation has crashed for me multiple times at the same point
installing the glibc rpm, off a CD.  The first few times I suspected that
it was perhaps a bad burn of the iso image, but it was reburned and still
had the same problem.  The only error/diagnostic messages I get are
installation program exited abnormally, then unmounting filesystems,
turning off swap, etc.

Comment 1 Jay Turner 2000-04-26 20:35:59 UTC
What kind of Sparc station is this?  What installation type are you performing?

Comment 2 sherrill 2000-05-01 18:43:59 UTC
I have the same type of problem, both in graphical and text-based install.
Everything seems to go fine right up to the point of laying the RPMs on the
disk.  The symptoms are various:

Signal 11 exit - must reboot
Signal 7 exit - must reboot
Installer hangs, no progress right after glibc (waited several hours)
Hangs, no progress right after disk format
Hangs, no progress during disk format

This is a SparcStation 5, 64 MB Ram, 2.1 GB SCSI internal, stock Sun video & TP
ethernet onboard.  Very annoying, making me consider Mandrake/SPARC instead.....

Comment 3 sherrill 2000-05-01 18:48:59 UTC
Oh yeah, not only both graphic and text install, but every type of install I
try including Gnome, KDE, server, and custom.  glibc-2.1.3-15 is in all of
these I believe ;-)

Comment 4 Jay Turner 2000-05-02 14:19:59 UTC
sherrill@ti.com: the only thing that I can imagine from the variety of the error
messages you are getting is that you are having hardware problems.  The signal 7
that you received is a "bad memory access" error, and the other errors could be
the result of that.  We have a SS5 in the lab, so I am going to attempt an
installation on it.  What installation method are you using (CDROM, NFS, etc.)?

Comment 5 Jay Turner 2000-05-02 14:33:59 UTC
I just performed a NFS installation (default package selection) on a
SparcStation 5 in the test lab in text-mode without any problems.

Comment 6 pugfantus 2000-05-19 16:08:59 UTC
Hello all,
	I'm also getting this problem on my Sparc5.  It just stops ~60% thru installing
glibc.  After about 30 secs, a white border appears around the screen, and I'm
forced to do a stop-a and reboot.  All the normal keys stop working, so I can't
get any errors.  We are tring other machines as I type, so I'll let you know.

--pug

Comment 7 Geoff Reedy 2000-05-19 19:17:59 UTC
Mine is a SparcStation 5 as well.  It has 128 megs of ram and has
the same symptoms as pug.  I've only tried a CD install since thats
the only removeable media it has, so booting for a net install is
a little difficult.

Comment 8 Michael Fulbright 2000-06-12 19:01:47 UTC
Test lab please try to replicate.

Comment 9 Brock Organ 2000-06-21 00:07:48 UTC
unable to replicate in test lab ...

Comment 10 Need Real Name 2000-08-08 00:41:42 UTC
I too have a SS5, 64Mb, 4Gb IBM, CD.  Installing off the CDROM locks 
up the installer - occurs during the "Installing Packages" phase.
Heard what I thought were SCSI resets until the lockup occurred.

Quite annoying... pls resolve ASAP!

Comment 11 sherrill 2000-08-08 16:03:52 UTC
I have installed Solaris 8 (initial release) on the same SparcStation 5 with no 
problems at all.  Since Sun now includes a lot of the GNU tools (on a separate 
CD) and source is available (though not "open/free" in the GPL manner), you 
might want to take a closer look.

Comment 12 Need Real Name 2000-08-10 05:42:40 UTC
Thanks Sherill... I need Linux for some experimentation I'm doing which I can't
do on SunOS.

By some fluke (I suppose after 20 or so attempts) the install completed.  I did
some things (modifying SCSI ID of the HDD and using a different CDROM drive)
but I don't believe these had much to do with it.  Also, I only used the CDROM
to boot, and installed the packages via FTP.

With redhat installed, I now get sporadic lockups - the longest the machine has
been up is a few hours, with the average being maybe 10 minutes depending on
what I'm doing on the machine (I just did a 'ps' before writing in this comment
and the machine hung.  I guess this means it's not just the CD installation that's
the problem, but a much broader SCSI issue.

The problem is definetely SCSI related.  I wonder if it's related to bug ID 4608
and other similar SCSI-related issues.


Comment 13 Brock Organ 2000-08-31 22:59:17 UTC
thanks to all for following up on this issue ... it seems clear that you are
having a frustrating time with this issue ... we are not able to duplicate this
problem with our test lab equipment (Sparc 5, Sparc 20, Axil ...)

... I will mark this issue as deferred to a future release ... thank you for
your efforts ...!

Comment 14 Michael Fulbright 2001-09-14 16:34:44 UTC
SPARC is not a supported platform.


Note You need to log in before you can comment on or make changes to this bug.