Bug 10916 - Cannot create Linux partition on drive with existing NTFS
Cannot create Linux partition on drive with existing NTFS
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
6.2
i386 Linux
medium Severity high
: ---
: ---
Assigned To: David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-04-19 10:28 EDT by David Lawrence
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-04-19 15:44:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Lawrence 2000-04-19 10:28:11 EDT
I attempted to install RedHat 6.2 on my Dell Inspiron 3700 laptop that has
a preexisting Windows 2000 NTFS partition.  I can add a swap partition just
fine, but when I attempt to add a Linux native partition, I get an error
stating that the partition is too large.  I attempted to specify a smaller
partition, with the same results.  I have tried everything from a 1Gb to
4+Gb partition size, and no luck.

Interestingly enough, after I rebooted into Windoze, I now have an
additional 0Mb logical partition (unformatted)... even after removing the
swap and Linux native partitions.  /-:

I believe this was a problem under 6.1 as well and thought it had been
fixed.
Comment 1 Jay Turner 2000-04-19 15:44:59 EDT
This is definitely not the problem that you were seeing in 6.1.  The problem
which is causing this message with the 6.2 installation is that you are
attempting to put the /boot partition outside of the 1024 cylinder limit.  The
installer is complaining because under this condition, you will not be able to
boot linux.

There are a couple of options that you can try.  You can attempt to create a
small partition (something like 16-32M) right at the end of the NTFS partition
and assign this as root.  This will work fine, depending on the size of the NTFS
partition.  In other words, as long as that new partition lies below the 1024
cylinder limit, this solution will work for you.  Once you have that partition
defined, you can create the other partitions that you would like on your system.

If you are not going to be able to create a partition below the 1024 cylinder
limit, then you are going to have to use a thrid-party utility to create space
below this 1024 cylinder limit.
Comment 2 jszabo 2000-05-13 17:19:59 EDT
I read on freshmeat (4/26) that lilo 0.21.4.2 can go up to 2 TB

Joe
Comment 3 Craig Kisely 2000-05-15 14:25:59 EDT
There seems to be an error... I am listed as the originator of this bug...
but I was not. You may want to check and see if you can find the original
reporter of this bug.

Note You need to log in before you can comment on or make changes to this bug.