Bug 109160 - saving a provided kernel config from xconfig gives errors (CONFIG_ZLIB_INFLATE & CONFIG_ZLIB_DEFLATE) and compilation of kernel fails. words: zlib kernel xconfig
saving a provided kernel config from xconfig gives errors (CONFIG_ZLIB_INFLAT...
Status: CLOSED DUPLICATE of bug 88129
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-05 02:09 EST by Bennett Feitell
Modified: 2015-01-04 17:03 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:59:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bennett Feitell 2003-11-05 02:09:36 EST
Description of problem:


Version-Release number of selected component (if applicable):
Fedora Severn Test3

How reproducible: every time


Steps to Reproduce:
1.  open kernel-2.4.22-i686.config in make xconfig
2.  "store configuration to file" with a different name
3.  Errors are dropped and CONFIG_ZLIB_INFLATE=m and  
CONFIG_ZLIB_DEFLATE=m are defined in the resulting saved config
Compilation fails with errors re: zisofs

  
Actual results:  Errors and compilation failure


Expected results:  No errors and a shiny new kernel


Additional info:
N.B. reccomendation on #fedora-devel to "export CC=gcc322" before
beginning makes no difference in outcome.
Comment 1 Bennett Feitell 2003-11-05 02:10:11 EST
Errors on save:
ERROR - Attempting to write value for unconfigured variable
(CONFIG_ZLIB_INFLATE).
ERROR - Attempting to write value for unconfigured variable
(CONFIG_ZLIB_DEFLATE).

Errors on Compile:
fs/fs.o(.text+0x30751): In function `isofs_put_super':
: undefined reference to `unload_nls'
fs/fs.o(.text+0x315eb): In function `isofs_read_super':
: undefined reference to `load_nls'
fs/fs.o(.text+0x3160d): In function `isofs_read_super':
: undefined reference to `load_nls_default'
fs/fs.o(.text+0x317fd): In function `isofs_read_super':
: undefined reference to `unload_nls'
fs/fs.o(.text+0x33de6): In function `wcsntombs_be':
: undefined reference to `utf8_wctomb'
fs/fs.o(.text+0x34378): In function `zisofs_readpage':
: undefined reference to `zlib_inflateInit_'
fs/fs.o(.text+0x34454): In function `zisofs_readpage':
: undefined reference to `zlib_inflate'
fs/fs.o(.text+0x344e2): In function `zisofs_readpage':
: undefined reference to `zlib_inflateEnd'
fs/fs.o(.text.init+0xeeb): In function `zisofs_init':
: undefined reference to `zlib_inflate_workspacesize'
make[1]: *** [kallsyms] Error 1
make[1]: Leaving directory `/usr/src/linux-2.4.22-1.2088.nptl'
make: *** [vmlinux] Error 2
Comment 2 Bennett Feitell 2003-11-05 02:25:12 EST
Testing this with make menuconfig does not drop errors but the saved
config file includes statically compiled zlib routines while the
xconfig way trys to make them as modules.  ZLIB does not appear
anywhere in the original config file and are not even available as
options in menuconfig while in xconfig they are greyed out.

-- tail of file saved from menuconfig
#
# Library routines
#
CONFIG_CRC32=y
CONFIG_ZLIB_INFLATE=y
CONFIG_ZLIB_DEFLATE=y
CONFIG_FW_LOADER=m

Comment 3 Peter van Egdom 2004-02-20 15:27:34 EST
I noticed this problem too with building kernel 2.4.x in Fedora Core 1.

The old kernel 2.4.x build system was a bit flaky and is much improved
(upstream) in kernel 2.6.x.

Fedora Core release 1.90 (FC2 Test 1) contains kernel 2.6.x.

With kernel 2.6.1-1.65 (I'm running FC2 Test 1) I don't have this
problem anymore.

This bug appears to be also a duplicate bug report. See Bugzilla Bug
88129 for more information.
Comment 4 Miloslav Trmac 2004-03-01 04:24:57 EST

*** This bug has been marked as a duplicate of 88129 ***
Comment 5 Red Hat Bugzilla 2006-02-21 13:59:45 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.