Bug 109171 - PatternStylesheetResolver should be the default setting
Summary: PatternStylesheetResolver should be the default setting
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Web Application Framework
Classification: Retired
Component: other   
(Show other bugs)
Version: nightly
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Vadim Nasardinov
QA Contact: Jon Orris
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 106597 108156
TreeView+ depends on / blocked
 
Reported: 2003-11-05 13:54 UTC by Daniel Berrange
Modified: 2007-04-18 16:59 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-11-06 23:41:10 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Daniel Berrange 2003-11-05 13:54:54 UTC
Description of problem:

The enterprise.init file setting for templating stylesheet resolver
was defaulted to 'PatternStylesheetResolver', however when
c.a.templating.Initializer was removed, the default was reverted to
the LegacyStylesheetResolver. 

The LegacyStyleshsetResolver should not be default since it based on
the deprecated SiteNode & PacakgeType APIs & it severly limited in its
functionality. Since I submitted p4 35159, PatternStylesheetResolver
is fully operational for Core & CMS out of the box.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Richard Li 2003-11-05 14:16:12 UTC
Ah, good ticket. A similar conclusion is being reached on bug 108156.

Comment 2 Vadim Nasardinov 2003-11-06 18:02:13 UTC
Addressed with change 37765.


Note You need to log in before you can comment on or make changes to this bug.