Bug 109281 - No mechanism to let projects provide a custom web.xml for the ROOT webapp.
No mechanism to let projects provide a custom web.xml for the ROOT webapp.
Status: CLOSED RAWHIDE
Product: Red Hat Web Application Framework
Classification: Retired
Component: other (Show other bugs)
nightly
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dennis Gregorovic
Jon Orris
:
Depends On:
Blocks: 109665
  Show dependency treegraph
 
Reported: 2003-11-06 10:09 EST by Daniel Berrange
Modified: 2007-04-18 12:59 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-12-04 17:09:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Berrange 2003-11-06 10:09:35 EST
Description of problem:

See following mail thread:

From: Justin Ross <jross@redhat.com>
X-X-Sender: justin@spellingbee.boston.redhat.com
To: Dennis Gregorovic <dgregor@redhat.com>
cc: "Daniel P. Berrange" <berrange@redhat.com>, Justin Ross
<jross@redhat.com>,
   "Rafael H. Schloming" <rafaels@redhat.com>, Scott Seago
<sseago@redhat.com>,
   Randy Graebner <randyg@redhat.com>, Brian Stein <bstein@redhat.com>
Subject: Re: web.xml for ROOT webapp

This sounds good to me.

Justin

On Fri, 17 Oct 2003, Dennis Gregorovic wrote:

> I'm cool with this.  Justin, Rafi: any objections?
>
> -- Dennis
>
> On Fri, 2003-10-17 at 14:41, Daniel P. Berrange wrote:
> > Since we are not going to have each application running in its own
> > webapp for the Oct 31st deliverable, we need to have a way to add
> > app-specific elements to the web.xml for the ROOT webapp. Prior to
> > test-packaging, we had the servlet-mappings.xml &
servlet-declarations.xml
> > interpolation, but this was really hairy & troublesome code which
> > we don't really want to bring back. In addition, the contents of the
> > web.xml for the ROOT webapp should really be under the control of
> > the project developer, (not the application developers) since it
> > dictates site-wide policy to a large extent.
> >
> > Thus I'd like to suggest a simpler alternative:
> >
> >   * Rename core/web/WEB-INF/web.xml to web.xml-default
> >
> >   * Projects can add alternate web.xml in (for example)
> >     aplaws/web/WEB-INF/web.xml-aplaws
> >
> >   * Application can provide *example* fragments, but this
> >     are not added in unless the project developer explicitly
> >     copies them. This would be cms/web/WEB-INF/web.xml.example.cms
> >
> >   * Extend the project.xml thus:
> >
> >     <ccm:project
> >           name="aplaws"
> >      shortName="aplaws"
> >        version="1.9.2"
> >        release="1"
> >         webxml="aplaws/web/WEB-INF/web.xml-aplaws"
> >      xmlns:ccm="http://ccm.redhat.com/ccm-project">
> >
> >
> >   * Modify the build-template.xsl to look for this attribute.
> >
> >     => If found, then after doing a 'deploy-config' it can
> >         copy 'web.xml-aplaws' to 'web.xml'.
> >
> >     => If not found, then copy web.xml-default to web.xml
> >
> >       (preserving backwards compat for
> >
> >   * A similar config option for production
> >
> >
> > NB, even when we do move all apps to their own webapps we will still
> > need the support for overriding the web.xml for the ROOT webapp to
> > add additional mappings at the root URL space. For example APLAWS
> > would use:
> >
> >    * A URL shortcuts filter 
(com.arsdigita.london.shortcuts.ShortcutFilter)
> >    * Site-wide prefix, eg /text
(com.arsdigita.web.InternalRedirectServlet)
> >    * Custom error JSP pages
> >    * etc,
> >
> > Dan.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Dennis Gregorovic 2003-11-24 11:55:39 EST
addressed on the devel side @38221 and on the depliy side @38244
Comment 2 Daniel Berrange 2003-11-27 10:25:11 EST
We still need to rename 'core/web/WEB-INF/web.xml' to
'core/web/WEB-INF/web.xml-default' otherwise the build tools will
never copy across custom one.
Comment 3 Dennis Gregorovic 2003-12-01 12:20:01 EST
12:22:03 dgregor@galileo foo4$ p4 describe -s 38379
Change 38379 by dennis@galileo-dennis on 2003/12/01 12:22:01

	ccm hostinit will now copy $CCM_HOME/webapps/ROOT/web.xml-default to
web.xml if CCM_WEBXML is not
	set and $CCM_HOME/webapps/ROOT/web.xml-default exists.  part of
	   https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=109281

Affected files ...

... //tools/ccmbuild/tools/dev/commands/hostinit#9 edit

Note You need to log in before you can comment on or make changes to this bug.