Bug 109294 - Mouse stops working when booting (with rhgb)
Mouse stops working when booting (with rhgb)
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: rhgb (Show other bugs)
1
athlon Linux
medium Severity high
: ---
: ---
Assigned To: Daniel Veillard
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-06 12:08 EST by Jean-Pascal Houde
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-11 17:31:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
My XF86Config (3.12 KB, text/plain)
2003-11-08 10:21 EST, Jean-Pascal Houde
no flags Details

  None (edit)
Description Jean-Pascal Houde 2003-11-06 12:08:58 EST
Description of problem:
When the graphical boot start, the mouse works OK.
After a few seconds (after "Loading local disks" or something like
that), the mouse stop working.
When X starts, the mouse still doesn't work.

My mouse is a Microsoft Intellimouse connected via USB.

Version-Release number of selected component (if applicable):
I don't know if the problem comes from redhat-config-mouse, XFree or
something else...

How reproducible:
At each boot.

Steps to Reproduce:
1. Install Fedora Core 1, select Generic 3 button USB Mouse.
2. Boot the new system.
  
Actual results:
The mouse doesn't work (can't move it, can't click) a few seconds
after the graphical boot appears.

Expected results:
The mouse continues to work as it should !

Additional info:
Comment 1 Jean-Pascal Houde 2003-11-08 10:17:18 EST
I've done some additional tests, and I've found that the problem only
occurs using rhgb. If if remove "rhgb" from the grub menu, the mouse
works perfectly when the X server starts.
However, when I use rhgb, it stops working after "Setting up local
disks" and I can't make it work exept by rebooting.

So I guess the problem is more with rhgb than redhat-config-mouse or
something else ?

Also, note that I didn't have this problem with test3.
Comment 2 Jean-Pascal Houde 2003-11-08 10:21:23 EST
Created attachment 95828 [details]
My XF86Config
Comment 3 Brent Fox 2004-01-12 17:53:45 EST
Changing component to rhgb.
Comment 4 Jean-Pascal Houde 2004-04-28 20:48:18 EDT
This problem seems to be fixed in FC2 test 3.
Comment 5 Daniel Veillard 2004-09-11 17:31:37 EDT
I assume it was a problem with the USB code, trashing your
mouse for some reason when starting support for USB drives.
I have an USB mouse too on a test box and can't reproduce the
problem either at this point.

  thanks,

Daniel

Note You need to log in before you can comment on or make changes to this bug.