Bug 109307 - Compile Failure with boost libraries
Compile Failure with boost libraries
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: boost (Show other bugs)
1
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Benjamin Kosnik
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-06 14:04 EST by Christian Loth
Modified: 2013-08-09 01:46 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-21 07:07:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christian Loth 2003-11-06 14:04:18 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1)
Gecko/20031030

Description of problem:
Compiling with boost triggeres the following errors:
/usr/include/boost/python/converter/as_to_python_function.hpp:28:
sorry, unimplemented: `
   method_call_expr' not supported by dump_expr
/usr/include/boost/python/converter/as_to_python_function.hpp:28:
sorry, unimplemented: `
   method_call_expr' not supported by dump_expr
/usr/include/boost/python/converter/as_to_python_function.hpp:28:
sorry, unimplemented: `
   method_call_expr' not supported by dump_expr
/usr/include/boost/python/converter/as_to_python_function.hpp:28:
sorry, unimplemented: `
   method_call_expr' not supported by dump_expr


Version-Release number of selected component (if applicable):
boost-1.30.2-2

How reproducible:
Always

Steps to Reproduce:
This seems to be a known compiler bug and there is a patch:
http://mail.python.org/pipermail/c++-sig/2003-May/004012.html

Actual Results:  Compile Failure

Expected Results:  Source compiles

Additional info:

Known bug, patch exists:
http://mail.python.org/pipermail/c++-sig/2003-May/004012.html
Comment 1 Panu Matilainen 2003-12-15 16:44:37 EST
This contains the patch mentioned above, no other changes compared to
FC1 boost package:
http://fedora.laiskiainen.org/SRPMS.patches/boost-1.30.2-3.src.rpm

Binaries in RPMS.patches for now (I needed this to get DIE to build :)
Comment 2 Benjamin Kosnik 2004-04-05 18:21:54 EDT
This is fixed in the boost-1.31.0-4 package.

-benjamin

Note You need to log in before you can comment on or make changes to this bug.