Bug 109316 - wrong blocksize setting
wrong blocksize setting
Status: CLOSED RAWHIDE
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: e2fsprogs (Show other bugs)
3.0
s390 Linux
medium Severity medium
: ---
: ---
Assigned To: Florian La Roche
Jay Turner
:
: 109434 (view as bug list)
Depends On:
Blocks: 106712
  Show dependency treegraph
 
Reported: 2003-11-06 14:57 EST by Florian La Roche
Modified: 2015-01-07 19:06 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-11-17 10:07:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Florian La Roche 2003-11-06 14:57:29 EST
Description of problem:
current e2fsprogs on mainframe sets the blocksize based on the
underlying blocksize. With SCSI and minimum blocksize of
512 bytes you then don't get ext2 blocksizes bigger than 1024.

Suggested solution: After setting the blocksize based on the size
of the partition, the blocksize should be checked to be big enough
for the underlying block device.

This can then also probably go into the upstream sources, as this
problem is also showing up for non-mainframe devices.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Florian La Roche 2003-11-11 09:20:40 EST
*** Bug 109434 has been marked as a duplicate of this bug. ***
Comment 2 Florian La Roche 2003-11-17 10:07:35 EST
New rpm is built into rawhide, thanks to Phil Knirsch.

greetings,

Florian La Roche

Note You need to log in before you can comment on or make changes to this bug.