This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 109334 - Mozilla crashes when trying use bookmarks file
Mozilla crashes when trying use bookmarks file
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: mozilla (Show other bugs)
1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Blizzard
Ben Levenson
:
: 109571 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-06 16:59 EST by Łukasz Trąbiński
Modified: 2007-11-30 17:10 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-12-02 16:01:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Łukasz Trąbiński 2003-11-06 16:59:57 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5b)
Gecko/20030831

Description of problem:
I have upgraded RH 9 to Fedora 1 core.
Mozilla crashed when I tried use my bookmarks. I have made:
strace -o file -f mozilla
it's look like this:

11788 open("/usr/share/fonts/ja/TrueType/kochi-gothic.ttf", O_RDONLY)
= -1 ENOENT (No such file or directory)
11788 munmap(0x41f56000, 244424)        = 0
11788 --- SIGSEGV (Segmentation fault) @ 0 (0) ---
11788 unlink("/home/lukasz/.mozilla/lukasz/96ylpit0.slt/lock") = 0
11788 exit_group(11)                    = ?
11795 <... poll resumed> [{fd=8, events=POLLIN}], 1, 2000) = 0
11795 getppid()                         = 1
11795 kill(11799, SIGKILL)              = 0
11795 kill(11798, SIGKILL)              = 0
11795 kill(11797, SIGKILL)              = 0
11795 kill(11796, SIGKILL)              = 0
11795 exit_group(0)                     = ?


Version-Release number of selected component (if applicable):
ttfonts-ja-1.2-29

How reproducible:
Always

Steps to Reproduce:
1. run mozilla
2. try use bookmarks
3.
    

Additional info:

I have resolved problem makink symblic link:
kochi-gothic.ttf -> kochi-gothic-subst.ttf
Now it's works fine.
I have tested it with mozilla from Fedora and mozilla 1.5b
Comment 1 Akira TAGOH 2003-11-06 17:53:35 EST
It means if the preference has the fonts which is no longer available,
mozilla crashes. it's not a font package bug.
Comment 2 jouni 2003-11-08 09:50:23 EST
Mozilla crashes to me too.  It happens to mee when I open
www.yahoo.com and after typing the string to search for and pushing
"yahoo! search".

Following is end of my trace:
fstat64(27, {st_mode=S_IFREG|0644, st_size=565716, ...}) = 0
mmap2(NULL, 565716, PROT_READ, MAP_PRIVATE, 27, 0) = 0xbdd0b000
close(27)                               = 0
mmap2(NULL, 528384, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS,
-1, 0) = 0xbdb7f000
munmap(0xbdb7f000, 528384)              = 0
munmap(0xbddbb000, 72496)               = 0
open("/usr/share/fonts/bitmap-fonts/6x13.pcf", O_RDONLY) = 27
fcntl64(27, F_SETFD, FD_CLOEXEC)        = 0
fstat64(27, {st_mode=S_IFREG|0644, st_size=495964, ...}) = 0
mmap2(NULL, 495964, PROT_READ, MAP_PRIVATE, 27, 0) = 0xbdb86000
close(27)                               = 0
mmap2(NULL, 528384, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS,
-1, 0) = 0xbdb05000
munmap(0xbdb05000, 528384)              = 0
munmap(0xbddcd000, 70121)               = 0
open("/usr/share/fonts/ja/TrueType/kochi-gothic.ttf", O_RDONLY) = -1
ENOENT (No such file or directory)
munmap(0xbdefc000, 60280)               = 0
--- SIGSEGV (Segmentation fault) @ 0 (0) ---
unlink("/root/.mozilla/default/8eomer4w.slt/lock") = 0
exit_group(11)                          = ?
[1]+  Exit 11                 mozilla

Comment 3 Need Real Name 2003-11-12 15:52:58 EST
*** Bug 109571 has been marked as a duplicate of this bug. ***
Comment 4 Wendigo 2003-11-13 20:31:30 EST
I had the same problem. I also did:

strace -o file -f mozilla

it shows:

5237  writev(3,
[{"\235\24\31\0\220\2\300\2\1\0\0\0Q\0\0\0\7\0\t\0\0\0\6\0"..., 2012},
{"\200\0\0\0\200\0\0\0\200 \0\0\376\177\0\0\202 \0\0\202"..., 64}], 2)
= 2076
5237  open("/usr/share/fonts/ja/TrueType/kochi-mincho.ttf", O_RDONLY)
= -1 ENOENT (No such file or directory)
5237  munmap(0xbdf62000, 72496)         = 0
5237  --- SIGSEGV (Segmentation fault) @ 0 (0) ---
5237  unlink("/home/Wendigo/.mozilla/profile/j79cps6a.slt/lock") = 0
5237  exit_group(11)                    = ?
5264  <... poll resumed> [{fd=6, events=POLLIN}], 1, -1) = -1 EINTR
(Interrupted system call)
5265  <... futex resumed> )             = -1 EINTR (Interrupted system
call)
5266  <... futex resumed> )             = -1 EINTR (Interrupted system
call)

As you can see my problem is with another font --> kochi-mincho
I made a simbolic link too

ln -s kochi-mincho-subst.ttf kochi-mincho.ttf

It solved the problem..
I had also upgraded from RH9 to Fedora.
Comment 5 JLapham 2003-11-19 06:21:32 EST
Yup, I'm seeing the same crash due to the missing kochi-mincho.ttf
font when performing searches on google.  Creating the sym link as
suggested above fixes the problem.

Might I suggest changing the title of this bug?  Bug 109571 was
correctly identified as a dup, but it had (IMO) a better title
"Mozilla crashes when viewing some character sets".

This bug really is more about the character set than bookmarks and
changing the title will help more people find this bug.
Comment 6 Dan Tucny 2003-11-22 08:28:41 EST
mozilla-1.4.1-18 fixes this as confirmed by vader in bug 109571 ...
someone want to close off this bug?
Comment 7 Łukasz Trąbiński 2003-11-22 10:00:56 EST
Well problem still extis if use mozilla-1.5 taken from ftp.mozilla.org.
I think that packages with fonts shuld be fix.
Comment 8 Christopher Blizzard 2003-12-02 16:01:27 EST
1.5 didn't include the fix.
Comment 9 Eric Li 2003-12-08 00:42:49 EST
FYI the font /usr/share/fonts/zh_CN/TrueType/zysong.ttf
which is part of the rpm package ttfonts-zh_CN
has been removed since version 2.13-0 of the package.  However
mozilla-1.4.1-18 and 1.5 both are not aware of this and attempts to
read the non-existent file, which results in a seg-fault.  
Work around:
create symlink to /usr/share/fonts/zh_CN/TrueType/gbsn00lp.ttf named
zysong.ttf

Note You need to log in before you can comment on or make changes to this bug.