Bug 109365 - Wireless Prism2 card detected as "Ethernet" not "Wireless"
Summary: Wireless Prism2 card detected as "Ethernet" not "Wireless"
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
(Show other bugs)
Version: 1
Hardware: i386 Linux
medium
low
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-11-07 03:04 UTC by Josiah Royse
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-28 18:18:46 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
kudzu -p output (3.49 KB, text/plain)
2003-11-07 03:07 UTC, Josiah Royse
no flags Details
lspci output (1008 bytes, text/plain)
2003-11-07 03:08 UTC, Josiah Royse
no flags Details

Description Josiah Royse 2003-11-07 03:04:18 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1)
Gecko/20031030

Description of problem:
The "Intersil PRISM2 11 Mbps Wireless Adapter" was previously detected
as TYPE=Wireless in the /etc/sysconfig/network-scripts/ifcfg-eth1. 
Now it shows up as TYPE=Ethernet which doesn't allow for an ESSID, and
WEP key in the network configurator.

Version-Release number of selected component (if applicable):


How reproducible:
Didn't try

Steps to Reproduce:
1. Install Fedora 1.0
2. set manual ip addresses for eth0 and eth1
3. try to set WEP, and SSID with GUI tools
    

Actual Results:  No GUI option for SSID and WEP, TYPE=Ethernet in
ifcfg-eth1

Expected Results:  GUI options for SSID and WEP, TYPE=Wireless in
ifcfg-eth1

Additional info:

Auto-detected in earlier versions.. RH 9?

Comment 1 Josiah Royse 2003-11-07 03:07:50 UTC
Created attachment 95786 [details]
kudzu -p output

Comment 2 Josiah Royse 2003-11-07 03:08:36 UTC
Created attachment 95787 [details]
lspci output

Comment 3 Bill Nottingham 2003-11-07 05:35:38 UTC
How did you initially configure the card?

Comment 4 Josiah Royse 2003-11-07 16:37:45 UTC
In the "Description of problem" when I said "previously" I really
meant "in past releases".  The card (Dell True Mobile Prism2) was in
the laptop at boot, and during the install of a fresh Fedora 1.0
install the two cards were configured with static ip addresses.  Sorry
for the confusion.  I didn't attach the
/etc/sysconfig/network-scripts/ifcfg-eth1 - but it had TYPE="Ethernet"
instead of the "Wireless" and was strangely missing the:

# Card Comments

section at the top like the 3com built-in NIC got on it's ifcfg-eth0
file.  Is Kudzu the right component?  

Comment 5 Bill Nottingham 2003-11-07 16:45:50 UTC
So, /etc/sysconfig/network-scripts/ifcfg-eth1 was existing directly
after install?

Comment 6 Josiah Royse 2003-11-07 17:58:27 UTC
Exactly.  The ifcfg-eth1 file for the Prism2 was filled with the right
information directly after boot, however it had the TYPE variable
wrong.  Since the TYPE was set to Ethernet, the GUI tools don't allow
the user to set WEP settings.

Comment 7 Bill Nottingham 2005-04-28 17:53:48 UTC
Does this persist with later releases?


Note You need to log in before you can comment on or make changes to this bug.