Bug 109379 - Adding printer does not work
Adding printer does not work
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: cups (Show other bugs)
9
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-07 06:16 EST by Allan Grunert
Modified: 2007-04-18 12:59 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-11-17 10:23:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
printconf-tui --Xexport (2.03 KB, text/plain)
2003-11-07 08:29 EST, Allan Grunert
no flags Details
client.conf (2.13 KB, text/plain)
2003-11-12 12:47 EST, Allan Grunert
no flags Details

  None (edit)
Description Allan Grunert 2003-11-07 06:16:02 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686) Gecko/20030428 Galeon/1.3.3

Description of problem:
If I complete to set up my Brother HL-4-Ve (with HP 3P Driver) with
the redhat-config-printer tool no test page can be printed. 

The printer is connected to /dev/lp0 and answers if I send something
with cat.

The cups webui does neither let me set up the printer. No devices
(e.g. /dev/lp0) can be selected.

Version-Release number of selected component (if applicable):
cups-1.1.17-13.3.0.3

How reproducible:
Always

Steps to Reproduce:
1. I install my printer with the redhat-config-printer tool
2. I complete the configuration and try to print a test page
    

Actual Results:  Error Message: "lpr: unable to print file:
server-error-service-unavailable"


Expected Results:  Printing should work.
Comment 1 Tim Waugh 2003-11-07 07:02:44 EST
How about if you try this:

Add the printer but don't print a test page when prompted.
Click 'Apply' to save the changes.
Select the printer and print a test page from the menu.
Comment 2 Allan Grunert 2003-11-07 07:57:39 EST
If I do this the same error message is displayed :(
Comment 3 Tim Waugh 2003-11-07 08:02:23 EST
What version of redhat-config-printer do you have?
Comment 4 Allan Grunert 2003-11-07 08:14:51 EST
Version 0.6.47.11
Comment 5 Tim Waugh 2003-11-07 08:19:05 EST
Please attach the output of 'printconf-tui --Xexport'.
Comment 6 Allan Grunert 2003-11-07 08:29:53 EST
Created attachment 95792 [details]
printconf-tui --Xexport
Comment 7 Tim Waugh 2003-11-07 08:32:56 EST
What does 'lpstat -s' say, from the command line?
Comment 8 Allan Grunert 2003-11-07 08:55:25 EST
It gives the following message:
lpstat: Unable to connect to server: Connection refused
Comment 9 Tim Waugh 2003-11-07 08:58:17 EST
What are the last few lines of /var/log/cups/error_log?
Comment 10 Allan Grunert 2003-11-07 09:05:57 EST
I [07/Nov/2003:15:08:14 +0100] Listening to 7f000001:631
I [07/Nov/2003:15:08:14 +0100] Configured for up to 100 clients.
I [07/Nov/2003:15:08:14 +0100] Allowing up to 10 client connections
per host.
I [07/Nov/2003:15:08:14 +0100] LoadPPDs: Read "/etc/cups/ppds.dat", 13
PPDs...
I [07/Nov/2003:15:08:14 +0100] LoadPPDs: No new or changed PPDs...
Comment 11 Tim Waugh 2003-11-07 11:37:27 EST
What does 'service cups status' say?
Comment 12 Allan Grunert 2003-11-08 07:40:15 EST
It says:
cupsd (pid 2921) wird ausgeführt... 

(= is running)

and ps x shows the following:
2921 ?        S      0:00 cupsd
Comment 13 Tim Waugh 2003-11-10 04:55:32 EST
As root please do this:

netstat -tlp
Comment 14 Allan Grunert 2003-11-11 12:37:19 EST
Aktive Internetverbindungen (Nur Server)
Proto Recv-Q Send-Q Local Address           Foreign Address         State
PID/Program name
tcp        0      0 *:20000                 *:*                     LISTEN
2564/OpenGroupware
tcp        0      0 *:32768                 *:*                     LISTEN
2457/rpc.statd
tcp        0      0 *:20001                 *:*                     LISTEN
2563/xmlrpcd
tcp        0      0 *:mysql                 *:*                     LISTEN
2837/mysqld
tcp        0      0 *:netbios-ssn           *:*                     LISTEN
3044/smbd
tcp        0      0 *:sunrpc                *:*                     LISTEN
2438/portmap
tcp        0      0 *:http                  *:*                     LISTEN
2880/httpd
tcp        0      0 *:ssh                   *:*                     LISTEN
2539/sshd
tcp        0      0 localhost:ipp           *:*                     LISTEN
2963/cupsd
tcp        0      0 *:postgres              *:*                     LISTEN
2930/postmaster
tcp        0      0 *:23000                 *:*                     LISTEN
2565/ZideStore
tcp        0      0 localhost:smtp          *:*                     LISTEN
2850/sendmail: acce
tcp        0      0 *:x11-ssh-offset        *:*                     LISTEN
6182/sshd
tcp        0      0 *:https                 *:*                     LISTEN
2880/httpd
Comment 15 Tim Waugh 2003-11-11 12:49:12 EST
And now what does lpstat -s say?
Comment 16 Allan Grunert 2003-11-11 12:59:07 EST
lpstat: Unable to connect to server: Connection refused
Comment 17 Tim Waugh 2003-11-11 13:02:01 EST
How about 'strace -econnect lpstat -s'? (You might have to install the
'strace' package.)
Comment 18 Allan Grunert 2003-11-11 13:04:11 EST
connect(3, {sa_family=AF_UNIX, path="/var/run/.nscd_socket"}, 110) =
-1 ENOENT (No such file or directory)
connect(3, {sa_family=AF_INET, sin_port=htons(631),
sin_addr=inet_addr("127.0.0.1")}, 16) = 0
connect(4, {sa_family=AF_UNIX, path="/var/run/.nscd_socket"}, 110) =
-1 ENOENT (No such file or directory)
connect(4, {sa_family=AF_INET, sin_port=htons(631),
sin_addr=inet_addr("127.0.0.1")}, 16) = 0
connect(4, {sa_family=AF_UNIX, path="/var/run/.nscd_socket"}, 110) =
-1 ENOENT (No such file or directory)
connect(4, {sa_family=AF_INET, sin_port=htons(631),
sin_addr=inet_addr("127.0.0.1")}, 16) = 0
connect(4, {sa_family=AF_UNIX, path="/var/run/.nscd_socket"}, 110) =
-1 ENOENT (No such file or directory)
connect(4, {sa_family=AF_INET, sin_port=htons(631),
sin_addr=inet_addr("127.0.0.1")}, 16) = 0
no system default destination
Comment 19 Allan Grunert 2003-11-11 13:05:17 EST
ups sorry that was the wrong pc...
Comment 20 Allan Grunert 2003-11-11 13:08:57 EST
Here is the correct output:
connect(3, {sa_family=AF_UNIX, path="/var/run/.nscd_socket"}, 110) =
-1 ENOENT (No such file or directory)
connect(3, {sa_family=AF_INET, sin_port=htons(631),
sin_addr=inet_addr("192.168.77.9")}, 16) = -1 ECONNREFUSED (Connection
refused)
lpstat: Unable to connect to server: Connection refused
Comment 21 Tim Waugh 2003-11-11 13:46:58 EST
So which machine is 192.168.77.9, and which machine is lpstat getting
run on?
Comment 22 Allan Grunert 2003-11-12 11:33:25 EST
192.168.77.9 is the machine on which cups is running and the printer
is connected to.Only in Comment #18 lpstat was run on another machine. 
Comment 23 Tim Waugh 2003-11-12 11:47:55 EST
Help me understand why the other machine is relevant.
Comment 24 Allan Grunert 2003-11-12 12:16:31 EST
No it is not. I used the wrong terminal by mistake. 
Comment 25 Tim Waugh 2003-11-12 12:30:25 EST
Okay.  What's in /etc/cups/client.conf?
Comment 26 Allan Grunert 2003-11-12 12:47:16 EST
Created attachment 95926 [details]
client.conf

I added client.conf as attachment. It seems to be empty.
Comment 27 Tim Waugh 2003-11-12 13:09:29 EST
What does 'echo $CUPS_SERVER' say?
Comment 28 Allan Grunert 2003-11-17 09:29:04 EST
echo $CUPS_SERVER gives no output.

In the /etc/hosts "127.0.0.1 localhost" was missing. 

Now lpstat -s gives the following output:
system default destination: printer
device for printer: parallel:/dev/lp0

But still no testpage is printed out.
Comment 29 Tim Waugh 2003-11-17 09:33:34 EST
Well, what happens?
Comment 30 Allan Grunert 2003-11-17 09:58:50 EST
After the change in /etc/hosts the cups logs said
/usr/lib/cups/filter/cupsomatic was missing so I reinstalled the
foomatic package.

The printer is working :)

Thank you very much!




Note You need to log in before you can comment on or make changes to this bug.