Bug 109442 - No option to check for bad blocks on formatting
No option to check for bad blocks on formatting
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
1
All Linux
medium Severity high
: ---
: ---
Assigned To: Michael Fulbright
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-07 15:53 EST by Dave
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-11-10 16:06:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dave 2003-11-07 15:53:56 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1)
Gecko/20031027

Description of problem:
There is no-longer any option to check for bad blocks when
partitioning/formatting the disk's at install time.

This is an item of functionality that really should be re-instated.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install fedora core
2. Select auto partition
3. Attempt to edit the partitions, there is no option to check the
partitions for bad blocks.
    

Actual Results:  erm... well it just creates the partitions and does a
quick format

Expected Results:  I wanted the option to scan the partitions I
created for bad blocks

Additional info:

There is a significant chance of data loss if users install to
partitions that they have no easy way of checking at install time.
Comment 1 Jeremy Katz 2003-11-10 16:06:38 EST
This was removed because it's destructive and by the time you've
checked you're in a situation of where you can do nothing to help the
user.  Also, badblocks was popping up some false positives in various
cases as well.

Note You need to log in before you can comment on or make changes to this bug.