Bug 109443 - A prelinked kuickshow crashes after being closed
A prelinked kuickshow crashes after being closed
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kdegraphics (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-07 16:01 EST by Dave Habben
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-28 08:47:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Backtrace (1.89 KB, text/plain)
2003-11-07 16:03 EST, Dave Habben
no flags Details

  None (edit)
Description Dave Habben 2003-11-07 16:01:47 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1)
Gecko/20031030

Description of problem:
This is on a clean install of Fedora Core 1. I ran kuickshow for the
first time as root. Without clicking on anything or making any changes
I closed the window, after this kuickshow crashes.

The backtrace will be attached.

Version-Release number of selected component (if applicable):
kdegraphics-3.1.4-1

How reproducible:
Always

Steps to Reproduce:
1. Run kuickshow
2. Close kuickshow
Comment 1 Dave Habben 2003-11-07 16:03:08 EST
Created attachment 95806 [details]
Backtrace
Comment 2 Ngo Than 2003-11-11 04:51:20 EST
It's strange, i cannot reproduce this problem with FC 1 here

There's nothing in the backtrace!
Are you sure that you have done a clean installation of FC 1?

please reopen this bug again if you could give me a better testcase
how i can reproduce this problem. thanks
Comment 3 Dave Habben 2003-11-11 16:59:34 EST
I just reproduced it again here on a second machine, this was also a
clean install. The problem only seems to be triggered after prelink is
run. So here is the method I used to reproduce it:

1. Clean install of FC 1, (Selected Workstation, + KDE + KDE Development)
2. Login as root
3. Run kuickshow & close it  (Works perfectly, tested this twice)
4. Run /etc/cron.daily/prelink (Wait about an hour)
5. Run kuickshow & close it  (Crashes with an empty backtrace every time)
Comment 4 Dave Habben 2004-02-13 07:46:58 EST
With FC 1.90 Test 1 this is still occuring, after prelink is ran on
the kuickshow binary it crashes with the following backtrace.
kuickshow no longer crashes if I run the following command:

prelink -u /usr/bin/kuickshow

Backtrace from a prelinked kuickshow:
(no debugging symbols found)...Using host libthread_db library
"/lib/tls/libthread_db.so.1".
(no debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...[Thread
debugging using libthread_db enabled]
[New Thread -1207700736 (LWP 2497)]
(no debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...0x00881a52
in _dl_sysinfo_int80 () from /lib/ld-linux.so.2
#0  0x00881a52 in _dl_sysinfo_int80 () from /lib/ld-linux.so.2
#1  0x00afa923 in __waitpid_nocancel () from /lib/tls/libpthread.so.0
#2  0x0050a261 in KCrash::defaultCrashHandler(int) ()
   from /usr/lib/libkdecore.so.4
#3  <signal handler called>
#4  0x0090b280 in _int_free () from /lib/tls/libc.so.6
#5  0x0090a1eb in free () from /lib/tls/libc.so.6
#6  0x0014f613 in KuickShow::~KuickShow() ()
   from /usr/lib/libkdeinit_kuickshow.so
#7  0x053ebe1c in QObject::event(QEvent*) ()
   from /usr/lib/qt-3.2/lib/libqt-mt.so.3
#8  0x0542324f in QWidget::event(QEvent*) ()
   from /usr/lib/qt-3.2/lib/libqt-mt.so.3
#9  0x054dcd82 in QMainWindow::event(QEvent*) ()
   from /usr/lib/qt-3.2/lib/libqt-mt.so.3
#10 0x05392c4f in QApplication::internalNotify(QObject*, QEvent*) ()
   from /usr/lib/qt-3.2/lib/libqt-mt.so.3
#11 0x0539225b in QApplication::notify(QObject*, QEvent*) ()
   from /usr/lib/qt-3.2/lib/libqt-mt.so.3
#12 0x00477e6d in KApplication::notify(QObject*, QEvent*) ()
   from /usr/lib/libkdecore.so.4
#13 0x05393a26 in QApplication::sendPostedEvents(QObject*, int) ()
   from /usr/lib/qt-3.2/lib/libqt-mt.so.3
#14 0x053a635c in QEventLoop::enterLoop() ()
   from /usr/lib/qt-3.2/lib/libqt-mt.so.3
#15 0x053a6228 in QEventLoop::exec() () from
/usr/lib/qt-3.2/lib/libqt-mt.so.3
#16 0x05392ea1 in QApplication::exec() ()
   from /usr/lib/qt-3.2/lib/libqt-mt.so.3
#17 0x0015985e in kdemain () from /usr/lib/libkdeinit_kuickshow.so
#18 0x0804869b in ?? ()
#19 0x00000004 in ?? ()
#20 0xbfe57db4 in ?? ()
#21 0xbfe57d88 in ?? ()
#22 0x008af405 in __libc_start_main () from /lib/tls/libc.so.6
Comment 5 Dave Habben 2004-02-13 11:58:11 EST
Since this seems to be an issue that prelink is causing I'll try to
reasign this issue to that component. Would this be a canidate for an
entry in the prelink.conf of:

-b /usr/bin/kuickshow
Comment 6 Jakub Jelinek 2004-02-17 06:17:37 EST
This doesn't look like prelink bug but kuickshow bug.
Try running
EF_ALLOW_MALLOC_0 LD_PRELOAD=libefence.so.0 kuickshow
on non-prelinked kuickshow binary.
It certainly crashes for me on exit as well, just like prelinked binary.
prelinking of course changes memory layout slightly, so it can trigger
a memory management bug in the app while it normally just happens to
work.
Comment 7 Dave Habben 2004-02-17 13:32:59 EST
Here is what I did, so you can catch any errors I made:
# up2date ElectricFence
# prelink -u /usr/bin/kuickshow
# export EF_ALLOW_MALLOC_0
# export LD_PRELOAD=libefence.so.0
# kuickshow

  Electric Fence 2.2.0 Copyright (C) 1987-1999 Bruce Perens
<bruce@perens.com>
 
  Electric Fence 2.2.0 Copyright (C) 1987-1999 Bruce Perens
<bruce@perens.com>
 
  Electric Fence 2.2.0 Copyright (C) 1987-1999 Bruce Perens
<bruce@perens.com>
 
  Electric Fence 2.2.0 Copyright (C) 1987-1999 Bruce Perens
<bruce@perens.com>
 
  Electric Fence 2.2.0 Copyright (C) 1987-1999 Bruce Perens
<bruce@perens.com>
QPixmap: Cannot create a QPixmap when no GUI is being used
QPixmap: Cannot create a QPixmap when no GUI is being used
 
ElectricFence Exiting: mprotect() failed: Cannot allocate memory
DCOP aborting call from 'anonymous-7913' to 'kded'
 
ElectricFence Exiting: mprotect() failed: Cannot allocate memory
[root@sinister root]# Mutex destroy failure: Device or resource busy
 
  Electric Fence 2.2.0 Copyright (C) 1987-1999 Bruce Perens
<bruce@perens.com>
 
  Electric Fence 2.2.0 Copyright (C) 1987-1999 Bruce Perens
<bruce@perens.com>
 
  Electric Fence 2.2.0 Copyright (C) 1987-1999 Bruce Perens
<bruce@perens.com>
 
  Electric Fence 2.2.0 Copyright (C) 1987-1999 Bruce Perens
<bruce@perens.com>

It came back to the shell prompt at that point without ever opening
kuickshow. 
Comment 8 Jakub Jelinek 2004-02-17 13:36:23 EST
How much memory do you have? EletricFence is quite memory hungry.
Anyway, until the memory management bugs in the app are solved,
there is no point in looking into whether there might be a prelink
problem as well or not.
Comment 9 Dave Habben 2004-02-17 13:49:26 EST
This machine has 512 MB, I can give it a try with 1 GB if you think
that would help.
Comment 10 Aaron Luchko 2004-05-19 14:11:43 EDT
Yeah got the bug here too with FC1.  The crash only occurs when I
close kuickview without having an image open (ie kuickview is in
filebrowser mode)
Comment 11 Ngo Than 2004-06-28 08:47:09 EDT
it's fixed FC2. I cannot reproduce it anymore.

Note You need to log in before you can comment on or make changes to this bug.