Bug 109447 - hwbrowser crashes after opening window
hwbrowser crashes after opening window
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: hwbrowser (Show other bugs)
1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-07 16:37 EST by Gérard Milmeister
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-02-19 18:56:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
My hwconf (5.37 KB, text/plain)
2003-12-05 11:43 EST, Gérard Milmeister
no flags Details

  None (edit)
Description Gérard Milmeister 2003-11-07 16:37:08 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1)
Gecko/20031030 Galeon/1.3.10

Description of problem:
This happened since RH90. Probably depends on my
hardware configuration.
The exact error is:
/usr/share/hwbrowser/hwbrowser: line 4: 18285 Segmentation fault     
/usr/bin/python /usr/share/hwbrowser/DeviceList.py
I can supply the needed information, if I am told which one.


Version-Release number of selected component (if applicable):
hwbrowser-0.12-1

How reproducible:
Always

Steps to Reproduce:
run hwbrowser

Additional info:
Comment 1 Tom Laudeman 2003-11-13 14:56:41 EST
This may be related:
Fedora Core 1, USB Microsoft blue optical wheel mouse. Running
hwbrowser from the menu under Gnome locks the cursor, and seems to
disable some keyboard function.

How reproducible:
about 95%
Comment 2 Brent Fox 2003-12-05 11:36:24 EST
gemi: can you attach your /etc/sysconfig/hwconf file?
Comment 3 Gérard Milmeister 2003-12-05 11:43:06 EST
Created attachment 96371 [details]
My hwconf
Comment 4 Brent Fox 2003-12-05 11:52:30 EST
Hmm, I can't explain why this is happening.  hwbrowser is written in
Python, so if you're seeing a segfault then something must be going
wrong below the Python level.

Try this:
1) log in as root
2) run 'python'
3) type 'import kudzu'
4) type 'list = kudzu.probe(kudzu.CLASS_AUDIO, kudzu.BUS_PCI,
kudzu.PROBE_ALL)'
5) type 'print list'

What is the output of step 5?
Comment 5 Gérard Milmeister 2003-12-05 12:00:31 EST
Step 5:
[Desc:           Intel Corp.|82801DB AC'97 Audio Controller
Driver:         i810_audio
Device:         None
, Desc:           Creative Labs|SB Live! EMU10k1
Driver:         emu10k1
Device:         None
]
Comment 6 Brent Fox 2003-12-05 12:04:22 EST
I'm sorry...I typed the wrong probing command.  Try 

list = kudzu.probe(kudzu.CLASS_AUDIO, kudzu.BUS_PCI,
kudzu.PROBE_ALL)

as step #4 instead.
Comment 7 Brent Fox 2003-12-05 12:06:31 EST
sorry, strike that.  My fingers move faster than my brain.

list = kudzu.probe(kudzu.CLASS_ALL, kudzu.BUS_PCI,
kudzu.PROBE_ALL)

That's the step 4 to use.
Comment 8 Gérard Milmeister 2003-12-05 12:39:37 EST
>>> list = kudzu.probe(kudzu.CLASS_ALL, kudzu.BUS_PCI, kudzu.PROBE_ALL)
Traceback (most recent call last):
  File "<stdin>", line 1, in ?
AttributeError: 'module' object has no attribute 'CLASS_ALL'
Comment 9 Brent Fox 2003-12-05 14:43:39 EST
Try:

list = kudzu.probe(kudzu.CLASS_UNSPEC, kudzu.BUS_UNSPEC, kudzu.PROBE_SAFE)
Comment 10 Gérard Milmeister 2003-12-05 16:11:35 EST
Output for kudzu.CLASS_UNSPEC


[Desc:           Intel Corp.|82801BA/CA/DB/EB PCI Bridge
Driver:         i810_rng
Device:         None
, Desc:           Intel Corp.|82801DB LPC Interface Controller
Driver:         i810-tco
Device:         None
, Desc:           Creative Labs|SB Live! MIDI/Game Port
Driver:         emu10k1-gp
Device:         None
, Desc:           Brooktree Corporation|Bt878 Audio Capture
Driver:         btaudio
Device:         None
, Desc:           Linux 2.4.22-1.2115.nptl ehci_hcd Intel Corp.
82801DB USB2
Driver:         unknown
Device:         None
, Desc:           Broadcom Corporation|BCM4401 100Base-T
Driver:         b44
Device:         eth0
, Desc:           Realtek|RTL-8029(AS)
Driver:         ne2k-pci
Device:         eth1
, Desc:           Initio Corporation|INI-940
Driver:         initio
Device:         None
, Desc:           Intel Corp.|82801DB AC'97 Audio Controller
Driver:         i810_audio
Device:         None
, Desc:           Creative Labs|SB Live! EMU10k1
Driver:         emu10k1
Device:         None
, Desc:           Plextor CD-R   PX-320A
Driver:         ignore
Device:         scd0
, Desc:           nVidia Corporation|NV28 [GeForce4 Ti 4800 SE]
Driver:         Card:NVIDIA GeForce 4 (generic)
Device:         None
, Desc:           3.5" 1.44MB floppy drive
Driver:         unknown
Device:         fd0
, Desc:           WDC WD800JB-00CRA1
Driver:         ignore
Device:         hda
, Desc:           WDC WD400BB-00AUA1
Driver:         ignore
Device:         hdb
, Desc:           WDC WD1600JB-00EVA0
Driver:         ignore
Device:         hdd
, Desc:           Iomega ZIP 100
Driver:         ignore
Device:         sda
, Desc:           Brooktree Corporation|Bt878 Video Capture
Driver:         bttv
Device:         None
, Desc:           Intel Corp.|82801DB USB (Hub #1)
Driver:         usb-uhci
Device:         None
, Desc:           Intel Corp.|82801DB USB (Hub #2)
Driver:         usb-uhci
Device:         None
, Desc:           Intel Corp.|82801DB USB (Hub #3)
Driver:         usb-uhci
Device:         None
, Desc:           Intel Corp.|82801DB USB2
Driver:         ehci-hcd
Device:         None
]
Comment 11 Brent Fox 2003-12-18 17:56:25 EST
Well, my suspicion was wrong.  I was thinking that somehow kudzu was
segfaulting on probing the hardware.  Your last post shows that the
probing is happening without any problems.  Since hwbrowser is written
in Python, usually you would see a Python traceback if the bug is in
the  Python code.  But since you're seeing a segfault, that usually
means that the crash is happening at some other level.  

Unfortunately, I don't have your exact hardware setup here and I'm not
able to reproduce this bug on any of my test machines.  


Comment 12 Brent Fox 2004-02-19 18:56:31 EST
Unfortunately, I have not been able to reproduce this bug on any of my
test machines.  I hate to do this, but I'm going to close this bug as
'worksforme'.  Without a reproducible test case, it's pretty difficult
to fix the bug.

Also, considering that this is the first bug report of this type I can
recall, I'm inclined to wonder if something isn't flaky with the
hardware.  Perhaps you could try removing the video capture card and
see if the problem still occurs.

If you try removing the card and that makes the problem go away, feel
free to reopen this bug and I'll try to dig deeper.

Note You need to log in before you can comment on or make changes to this bug.