Bug 109469 - traceback in lilo code
Summary: traceback in lilo code
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: up2date (Show other bugs)
(Show other bugs)
Version: 3.0
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Adrian Likins
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-11-08 03:13 UTC by Bill Nottingham
Modified: 2014-03-17 02:40 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-24 21:00:19 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
lilo config file (592 bytes, text/plain)
2003-11-17 19:22 UTC, Bill Nottingham
no flags Details

Description Bill Nottingham 2003-11-08 03:13:59 UTC
Description of problem:

Updating to the errata kernel:

   3:kernel-smp            
########################################### [100%]
Traceback (most recent call last):
  File "/usr/sbin/up2date", line 1165, in ?
    sys.exit(main() or 0)
  File "/usr/sbin/up2date", line 745, in main
    fullUpdate, dryRun=options.dry_run))
  File "/usr/sbin/up2date", line 1028, in batchRun
    batch.run()
  File "up2dateBatch.py", line 82, in run
  File "up2dateBatch.py", line 153, in __installPackages
  File "up2date.py", line 613, in installPackages
  File "up2date.py", line 662, in runPkgSpecialCases
  File "up2date.py", line 753, in installBootLoader
  File "up2date.py", line 768, in __install_lilo
  File "lilocfg.py", line 376, in installNewImages
up2date_client.lilocfg.LiloConfError: Error installing lilo.conf  The
message was:
test install of lilo failed

Comment 1 Adrian Likins 2003-11-17 17:19:56 UTC
cath the traceback with the u1 target code, but I'm not
sure why the test install fails.

could you attach the lilo.conf?



Comment 2 Bill Nottingham 2003-11-17 19:22:08 UTC
It's on devserv, but it's been modified since then.

Comment 3 Bill Nottingham 2003-11-17 19:22:47 UTC
Created attachment 96024 [details]
lilo config file

Comment 5 Adrian Likins 2004-01-20 19:15:50 UTC
what kernels are installed for those machines?

did the preexisting lilo work? 

Comment 6 Bill Nottingham 2004-01-20 20:22:09 UTC
On devserv, yes, the preexisting lilo did work. I'm guessing what
happened was just a too-long (or duplicate?) label.

Comment 7 Blurred Vision 2004-02-14 20:02:52 UTC
I am receiving this error too, on a clean install RHEL3 the first 
time up2date is run... I have this problem on 3 prd systems aswell, 
all minimum install RHEL3 the first time I run up2date...

Any help I can provide (as I have 4 systems all exhibiting the same 
symptoms?)
.
..
...
New Up2date available
Traceback (most recent call last):
  File "/usr/sbin/up2date", line 1165, in ?
    # we're fine up to this point...
  File "/usr/sbin/up2date", line 745, in main
    else:
  File "/usr/sbin/up2date", line 1028, in batchRun

  File "up2dateBatch.py", line 82, in run
  File "up2dateBatch.py", line 153, in __installPackages
  File "up2date.py", line 613, in installPackages
  File "up2date.py", line 662, in runPkgSpecialCases
  File "up2date.py", line 753, in installBootLoader
  File "up2date.py", line 768, in __install_lilo
  File "lilocfg.py", line 376, in installNewImages
up2date_client.lilocfg.LiloConfError: Error installing lilo.conf  The 
message was:
test install of lilo failed


Comment 8 Blurred Vision 2004-03-30 01:17:59 UTC
What is the time frame likely to fix this? this is causing major bad 
mojo with my kickstarts...  

Any ideas?

Blurred

Comment 9 Adrian Likins 2004-08-24 21:00:19 UTC
there was a bug with labels of exactly 15 chars that
should be fixed in current errata releases


Note You need to log in before you can comment on or make changes to this bug.