Bug 109501 - glibc-common needs to be split into seperate packages
glibc-common needs to be split into seperate packages
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: glibc (Show other bugs)
1
All Linux
medium Severity low
: ---
: ---
Assigned To: Jakub Jelinek
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-08 14:01 EST by Jim Nance
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-28 05:10:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jim Nance 2003-11-08 14:01:00 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20031016

Description of problem:
The glibc-common rpm contains over 70M of locale data.  Most people
only need one or two locales, so this is about 70M of wasted disk
space.  It would be good to take the locale data out of glibc-common
and create various glibc-locale-* rpms, so that people did not have to
install so many locales that they did not need.

I realize that it is not feasible to place every locale into a
seperate RPM.  However, if it was split up on a per-contenent basis it
should not be too bad.

Version-Release number of selected component (if applicable):
glibc-common-2.3.2-101.i386.rpm

How reproducible:
Always

Steps to Reproduce:
1.  du -sk /usr/lib/locale
2.
3.
    

Actual Results:  tricia> du -sk /usr/lib/locale/
72628   /usr/lib/locale


Additional info:
Comment 1 Ulrich Drepper 2004-09-28 05:10:06 EDT
The amount of work associated with this is too big.  It would require
extensive coordination with the installer which would need to be able
to determine automatically which packages to install.

If you want to help the installer guys to extend their code (and they
accept it) reopen the bug.  Until then I'll close it as WONTFIX.

Disk space is cheap.  Only downloading updates is bad but then this is
something which should be fixed there.  Since the file content hardly
changes using rsync or so in some form or another should help reducing
the cost significantly.
Comment 2 Jakub Jelinek 2004-09-28 05:15:55 EDT
Furthermore, when all locales are in one package, they can be hardlinked
together (e.g. many locales use the same CTYPE or COLLATE categories
with the same charsets, and those are the biggest ones).
If that is split into subpackages, we can't do that any longer.

Note You need to log in before you can comment on or make changes to this bug.