Bug 109542 - graphical installer uses wrong X settings on laptop external monitor
graphical installer uses wrong X settings on laptop external monitor
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
Depends On:
  Show dependency treegraph
Reported: 2003-11-09 00:53 EST by Daniel Lipsitt
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2004-10-05 11:33:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
logfiles for external and builtin cases (3.69 KB, application/x-tgz)
2003-11-10 17:25 EST, Daniel Lipsitt
no flags Details

  None (edit)
Description Daniel Lipsitt 2003-11-09 00:53:18 EST
From Bugzilla Helper: 
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.1; Linux) 
Description of problem: 
On my Dell Inspiron 8100 laptop with external monitor, graphical 
install fails if the external monitor is enabled. 
Anaconda detects my video card (NVidia GeForce 2 Go) and external 
monitor (Dell Ultrascan P991, a rebranded trinitron) correctly. I am 
guessing that it is maybe trying to use the X settings for the lcd 
on the external montior. 
I can toggle the display from external to lcd and back with a key on 
the keyboard. When I enable the lcd, I get static there as well. If 
I switch to a virtual console on the lcd, it is garbled but 
recognizable as text. If I then switch back into X, it is fine. If I 
switch back to the console again, I no longer get garbled text, but 
moving static instead. Switching the external monitor back on at any 
point results in an on-screen display reporting "out of scan range" 
There are no problems if I install with the external monitor turned 
off the whole time. 
This bug prevents install from proceeding, and would prevent a user 
who doesn't know how to kill X from performing a soft reboot. 
Version-Release number of selected component (if applicable): 
How reproducible: 
Steps to Reproduce: 
1. Do graphical install with external monitor turned on 
Actual Results:  Static on external monitor 
Additional info: 
I haven't been able to retrieve the X logs. Maybe I can if I switch 
to the lcd and kill X and then hit control-s during shutdown, but I 
haven't tried that yet.
Comment 1 Jeremy Katz 2003-11-10 16:30:23 EST
Can you attach the /tmp/XF86Config and /tmp/anaconda.log from having
both the external monitor attached and not?  You shouldn't have to
actually complete the install, just get to where X has started and you
can access tty2.
Comment 2 Daniel Lipsitt 2003-11-10 17:25:09 EST
Created attachment 95891 [details]
logfiles for external and builtin cases

I'm uploading a zipped tarball with subdirectories called crt and lcd. Each
contains X.log, XF86Config.test, and anaconda.log. Crt is the external monitor
(broken X config) and lcd is the builtin display (working). Let me know if you
want these files uploaded some other way.
Comment 3 Daniel Lipsitt 2003-11-10 17:38:16 EST
I diffed the crt and lcd directories and the only difference is a 
timestamp in X.log. 
Comment 4 Jeremy Katz 2003-11-12 10:11:46 EST
LCD is without the external monitor attached/powered on?  I don't see
how it could possibly probe a CRT without it actually being there...
Comment 5 Daniel Lipsitt 2003-11-13 11:24:03 EST
You're right, I probably just had it toggled off from the laptop
keyboard. This causes the external monitor to go to sleep, but it
might still be probed. When I get a chance I'll try it with the
monitor powered off.
Comment 6 Mark Derricutt 2004-02-20 23:50:26 EST
I noticed a similar but slightly different problem on my FC2-test1

The machine in question has an onboard SiS video card, and an addition
NVidia card installed.  The NVidia is set as the primary video and is
the only one used ( always had issues with the SiS in the past ).

Anaconda detected the SiS card, and went on to use this for the X11
install which failed, doing a text install worked, but X11 was setup
for XF86Config, and thus failed again.  Manually editing the
XF86Config for nvidia use allowed me to actually use the machine thou.

If this is different, should I open another issue for it?

Comment 7 Jeremy Katz 2004-10-05 11:33:20 EDT
This is all done differently in our current code, so I'm going to hope
that it's no longer a problem.  If you continue to experience this in
Fedora Core 3, please reopen or file a new report with details of what
you see there.

Note You need to log in before you can comment on or make changes to this bug.