Bug 10956 - Post-install scripts generate "File exists" Python exception
Post-install scripts generate "File exists" Python exception
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
6.2
i386 Linux
medium Severity high
: ---
: ---
Assigned To: David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-04-21 00:34 EDT by Remko Molier
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-04-21 07:07:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Remko Molier 2000-04-21 00:34:14 EDT
I did a custom install of RedHat Linux 6.2.  I've been doing a lot of
installs on the same machine lately, as I screw things up & have to redo
things, and so on.  But the only difference between my latest installation
(which broke) and the previous one (which didn't) was that I added a second
network card to the machine and changed one of the hard drives.

I'm guessing that adding the second network card is what confused the
installation, because it looks like it broke right around the time it was
doing network configuration.  The installed Linux figured out the second
network card without any trouble; it appears to just be the installation
that has a problem.

Screen 3 said:

* self.network.hostname = cx33665-a.vista1.sdca.home.com

Screen 1 said:

Exception in thread Thread-3:
Traceback (innermost last):
  File "/usr/lib/python1.5/threading.py", line 376, in __bootstrap
    self.run()
  File "/usr/lib/anaconda/iw/progress.py", line 16, in run
    rc = self.todo.doInstall ()
  File "/usr/lib/anaconda/todo.py", line 1252, in doInstall
    self.writeConfiguration ()
  File "/usr/lib/anaconda/todo.py", line 1065, in writeConfiguration
    self.writeNetworkConfig ()
  File "/usr/lib/anaconda/todo.py", line 531, in writeNetworkConfig
    ip = self.network.lookupHostname()
  File "/usr/lib/anaconda/todo.py", line 144, in lookupHostname
    self.gateway)
  File "/usr/lib/anaconda/isys.py", line 230, in configNetDevice
    return _isys.confignetdevice(device, ip, netmask, gw)
SystemError: (17, 'File exists')

My network config was:

eth0
----
Configure using DHCP: no
Activate on boot: yes
IP Address: 24.0.172.162
Netmask: 255.255.255.0
Network: 24.0.172.0
Broadcast:24.0.172.255

eth1
----
Configure using DHCP: no
Activate on boot: yes
IP address: 192.168.0.1
Netmask: 255.255.255.0
Network: 192.168.0.0
Broadcast: 192.168.0.255

Hostname: cx33665-a.vista1.sdca.home.com
Gateway: 24.0.172.1
Primary DNS: 24.0.3.33
Secondary DNS: 24.0.3.34
Ternary DNS: <blank>

The machine is a Pentium 90 with 32 megs of RAM and 11 gigs of hard drive
space.  I'm configuring it to be a gateway between the Internet and my own
private network.
Comment 1 Jay Turner 2000-04-21 07:07:59 EDT
This is a problem with having multiple NICs of the same type in the machine.  We
have fixed this issue and you can get the fix in the 4/19/00 updates disk
available from the Red Hat site, or from the mirror sites.  You will need to
download the update-disk-20000419.img disk as well as the new version of the
boot disks (download the appropriate boot disk for your installation method)
Comment 2 Anonymous 2000-04-22 20:09:59 EDT
Actually, the NICs are different.  One is a 3Com 3C590 and the other is a D-Link
DFE-530TX+.  I don't know if that affects the outcome.

And I was using the 4/7/00 boot disk, just so you know.

Note You need to log in before you can comment on or make changes to this bug.