Bug 109569 - Network interface intermittent on Toshiba TECRA 8200
Summary: Network interface intermittent on Toshiba TECRA 8200
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel   
(Show other bugs)
Version: 1
Hardware: i686
OS: Linux
medium
high
Target Milestone: ---
Assignee: Jeff Garzik
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-11-09 18:56 UTC by Paolo Prandini
Modified: 2013-07-03 02:16 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-03-18 14:10:51 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Paolo Prandini 2003-11-09 18:56:42 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1)
Gecko/20031030 Epiphany/1.0.4

Description of problem:
I have installed FC-1 on Toshiba TECRA 8200.
I have an ADSL Switch configured as a DHCP server,
with two PC connected : a custom made with RH9 and this TECRA 8200.
I have checked cables (swapping them) to exclude hardware problems
and configurations. All appear to be good.
The Network module loaded is e100. 
this is the output from ifconfig eth0
[root@localhost Add-on]# ifconfig eth0
eth0      Link encap:Ethernet  HWaddr 00:00:39:A9:F4:2E
          inet addr:192.168.2.147  Bcast:255.255.255.255 
Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:18970 errors:0 dropped:0 overruns:0 frame:0
          TX packets:16191 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:22962783 (21.8 Mb)  TX bytes:1577787 (1.5 Mb)
          Interrupt:11 Base address:0xdec0 Memory:f7df7000-f7df7038


Version-Release number of selected component (if applicable):
 2.4.22-1.2115.nptl

How reproducible:
Couldn't Reproduce

Steps to Reproduce:
1. Browse the Internet
2. at some point the connection is lost
3. do a /etc/init.d/network stop; /etc/init.d/network start
4. at this point the connection is up again
    

Actual Results:  Connection works again for a random period of time.

Expected Results:  No connection loss.

Additional info:

You can speed the connection loss (reducing the random time between
two failures) by wget to some site or running yum in the background.

Comment 1 Paolo Prandini 2003-11-09 18:57:20 UTC
RH9 was running fine on this same computer.

- Regards
- Paolo

Comment 2 Paolo Prandini 2003-11-09 19:16:35 UTC
Done some other testing, found a way to reproduce.
While browsing (ephipany or mozilla) simply initiate a big download,
like the JAVA 1.4.2_02 JRE or SDK and after 28-30 sec you the
connections hangs until you restart network interface.
Already tested 10 times, connection hangs always in 28-30 sec.
It seems something in the NIC module or Network isn't able to sustain
an high data rate (ADSL 640Kb) for more than 30 secs.
With pages or downloads that have a duration of some secs this does
not seem to happen or happes randomly.

- Hope it helps
- Regards
- Paolo

Comment 3 Paolo Prandini 2003-11-10 13:38:39 UTC
Hi 
I have done some other testing.
Mozilla or Epiphany doen't matter, network hangs again in the some
circumstances.
I have recompiled the kernel using 2.4.22 from kernel.org,
with all the necessary modules. The problem still persists.
The last kernel that I was running on this machine w/o problems was a
RH9 stock Kernel 2.4.20-20.9.i686. 
On the same machine I have Windows 2000 as a boot option. Tried out
Windows 2000 to download the same file and I succeded. This takes all
the hardware problems out of the game. 

- Hope it helps
- Regards
- Paolo

PS : If any suggestions, please do. I would not go back to RH9. I like
Fedora.... :-)


Comment 4 Jeff Garzik 2004-01-12 19:02:46 UTC
Does 'dmesg' produce any error messages related to e100?


Comment 5 Paolo Prandini 2004-01-19 19:29:56 UTC
No. 'dmesg' looks fine.


Comment 6 Brent Deterding 2004-01-29 17:56:47 UTC
I am also having this problem - although mine is with stock RH9.
Although mine doesn't seem too dependent on load - it will stop
working after a short period of time with zero network traffic.

I have a brand new Toshiba Satellite Pro 6100
I am using a freshly compiled e100 module from Intel (2.3.33)

Comment 7 Brent Deterding 2004-01-30 06:26:26 UTC
I apologize - although the problem persisted after unloading the stock
e100 module and reloading the new one a reboot seemed to fix the problem?

Comment 8 Paolo Prandini 2004-02-17 20:28:36 UTC
Hi, 

Yes a reboot gives me a goood fresh start, until I do not ftp
something ....

- regards
- Paolo


Note You need to log in before you can comment on or make changes to this bug.