Bug 109570 - Non-default paper size doesn't work with foomatic-generated PPD?
Non-default paper size doesn't work with foomatic-generated PPD?
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: foomatic (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-09 14:07 EST by Jonathan Kamens
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-15 11:31:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jonathan Kamens 2003-11-09 14:07:54 EST
I've got pretty current Raw Hide installed, e.g., foomatic-3.0.0-9.

If I generate a ppd file for my Deskjet 5550 using the hpijs driver,
then copy that PPD file over to a Mac running MacOS 9 to be used with
the Adobe PS driver to generate PostScript, the resulting PostScript
is displayed as Legal in "gv", but when I print it, ghostscript
apparently treats the paper size as 8.5x11 and thus truncates the top
3 inches of the printout.

When I examine the PPD file, I see that it has no /setpagedevice
directives to set the paper size when non-default paper sizes are
selected.  I imagine that this is the problem, because when I use
other ppd files which do contain setpagedevice commands, the hard copy
fills the whole 8.5x14 page as it should.
Comment 1 Tim Waugh 2003-11-10 04:57:52 EST
foomatic-3.0.0-11 has lots of bug fixes since 3.0.0-9.  When that
shows up in rawhide I'd be interested to know if this problem persists.
Comment 2 Jonathan Kamens 2003-12-14 13:50:05 EST
This is still broken in foomatic-3.0.0-12.  PPD files generated with
the hpijs driver do not have setpagedevice commands in them.  In
contrast, PPD files generated with the ljet4 driver do.

Comment 3 Tim Waugh 2004-01-28 07:33:29 EST
Is this the same as bug #114191?
Comment 4 Jonathan Kamens 2004-01-28 08:32:53 EST
Nope, different bug.  This bug is about the fact that since the PPD
generated by foomatic doesn't have the correct setpagedevice commands
in it, anything which uses that PPD to print is going to generate
incorrect PostScript.  The other bug about the fact is that hpijs
doesn't set the paper size properly at the PCL level even when the
PostScript has the correct setpagedevice command in it.
Comment 5 Bill Nottingham 2006-08-07 21:52:23 EDT
'Red Hat Raw Hide' refers to the development tree for Red Hat Linux.
Red Hat Linux is no longer supported by Red Hat, Inc. If you are still
running Red Hat Linux, you are strongly advised to upgrade to a
current Fedora Core release or Red Hat Enterprise Linux or comparable.
Some information on which option may be right for you is available at
http://www.redhat.com/rhel/migrate/redhatlinux/.

Red Hat apologizes that these issues were not resolved in a more
timely manner. However, we do want to make sure that important 
don't slip through the cracks. If these issues are still present
in a current release, such as Fedora Core 5, please move these
bugs to that product and version. Note that any remaining Red Hat
Raw Hide bugs will be closed as 'CANTFIX' on September 30, 2006.
Thanks again for your help.
Comment 6 Jonathan Kamens 2006-09-03 03:24:29 EDT
Still broken.
Comment 7 Tim Waugh 2006-12-15 11:31:50 EST
> If I generate a ppd file for my Deskjet 5550 using the hpijs driver,
> then copy that PPD file over to a Mac running MacOS 9 to be used with
> the Adobe PS driver to generate PostScript,

This is the problem.  The PPD is for the hpijs driver, not for PostScript.  Why
not use a PostScript PPD?

Note You need to log in before you can comment on or make changes to this bug.