Bug 109577 - overly wide character spacing with some fonts in gvim
overly wide character spacing with some fonts in gvim
Product: Fedora
Classification: Fedora
Component: vim (Show other bugs)
i386 Linux
low Severity low
: ---
: ---
Assigned To: Karsten Hopp
David Lawrence
Depends On:
  Show dependency treegraph
Reported: 2003-11-09 15:16 EST by Joel Uckelman
Modified: 2007-11-30 17:10 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2005-09-06 06:08:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Joel Uckelman 2003-11-09 15:16:49 EST
Description of problem:

Some monospace fonts have huge inter-character spacing in gvim. E.g.,
when Nimbus Mono L is selected as the display font, this approximates
 the result:

     C h a r a c t e r s  a r e  v e r y  s p r e a d  o u t .

Whereas with Monospace, the result is what you'd expect:

     Characters look normal.

(Hopefully I've reproduced the effect above. If not, I'll gladly
supply a screenshot.) This isn't a huge problem since there are
good-looking monospace fonts that display properly in gvim, but fixing
it would be a good thing if it's not too difficult.

If whoever gets this bug can't reproduce it, I'd be more than happy to
help troubleshoot it, since mine consistently works like this.

Version-Release number of selected component (if applicable):


Steps to Reproduce:
1. Start gvim.
2. Switch the font to Nimbus Mono L (among others).
3. ???
4. Profit! Er, look at the screen.
Actual results:

Intercharacter spacing is huge.

Expected results:

Intercharacter spacing is normal.
Comment 1 Karsten Hopp 2003-11-09 15:38:30 EST
does this happen in every locale ? If not, what's your $LANG set to 
Comment 2 Joel Uckelman 2003-11-09 15:51:57 EST
[uckelman@scylla uckelman]$ echo $LANG

I can't try gvim in any other locales at the moment, since I'm logged
in remotely, but I'll give that a shot when I return home.
Comment 3 Joel Uckelman 2003-11-09 20:13:31 EST
I've now tried running gvim with a few other locales (de_DE, ru_RU,
pt_BR) with the same results. This leads me to think the problem is
not locale-dependent.
Comment 4 Bret Hughes 2003-11-10 01:18:27 EST
I too see this and find it really irritating.  From what I can tell
all proportional fonts exhibit this behavior.  I switched default font
to courier and I hate it.

Mine is on a 7.1 box upgraded to fedora core if it matters.

Comment 5 Joel Uckelman 2003-11-10 01:48:32 EST
The help in gvim says of the 'guifont' option:

"Note that the fonts must be mono-spaced (all characters have the same

So you're not supposed to be able to use proportional fonts in gvim.
Which gives me an idea---could it be that gvim sees some fonts that
purport to be monospace as proportional instead?
Comment 6 sangu 2003-11-10 03:59:13 EST
<match target="font">
 		<test name="family">
			<string>Nimbus Mono L</string>		
       	 	<edit name="spacing">

please add to ~/.fonts.conf 
Comment 7 Joel Uckelman 2003-11-11 02:54:36 EST
1. The suggestion of adding something to my .fonts.conf in comment 6
had no noticeable affect for me.

2. I tried every monospace font I have, and found that the only one
with improper letter spacing in gvim is Nimbus Mono L. All of the
others (Andale Mono, Bitstream Vera Sans Mono, console8x16,
console8x8, Courier, Courier 10 Pitch, Courier New, Fixed, Gothic,
Lucida Typewriter, Luxi Mono, Miriam Mono, MiscFixed, Monospace) are
fine. On the other hand, Nimbus Mono L displays properly in all other
applications where I've tried it.

Hmm. This isn't much of a problem, but now I'm sort of intrigued.
What's different about this font from all the other monospace ones?
Comment 8 Serge 2004-02-03 02:30:07 EST
I tried the Nimbus Roman font which is a serif type font but it comes up
1- with overly wide spacing
2- As a sans-serif type font

Maybe gvim can't find the font and it is replacing with some ugly default
Comment 9 Serge 2005-02-09 01:48:29 EST
Occured in FC2 and is still present in FC3
Comment 10 Karsten Hopp 2005-09-06 06:08:44 EDT
It is still present in FC4 and Rawhide, but I just haven't any spare time to fix
this. I'll close this as WONTFIX now instead of having it open for ages without
any prospect of fixing it. Please reopen if you have a patch to fix it.
Comment 11 Joel Uckelman 2006-06-22 15:27:02 EDT
As of vim 6.4.007-4 in FC5, this bug is fixed.
Comment 12 Cody Lee 2006-09-14 22:07:18 EDT
This is simple solution :
Create below file.
set guifont=Courier

Note You need to log in before you can comment on or make changes to this bug.