Bug 109602 - Installer doesn't update boot loader if there's no kernel upgrade to do
Installer doesn't update boot loader if there's no kernel upgrade to do
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
1
i686 Linux
medium Severity low
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-09 21:06 EST by Neil Weisenfeld
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-11-10 16:41:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Neil Weisenfeld 2003-11-09 21:06:22 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5)
Gecko/20031007 Firebird/0.7

Description of problem:
I had already upgraded most of the RPMs, but ran the installer in
order to move grub from the root partition to the MBR.  But since the
kernel didn't need to be upgraded, grub was not reinstalled.  If the
user chooses "new bootloader install", then you should do that,
regardless of whether the kernel is upgraded 




Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
From memory, I hope that it's accurate

1. Have a system with Grub installed at the start of the root partition
2. Boot the update/install disk 
3. Select the "install new bootloader configuration" option
4. Continue

It will indicate that no changes were made to the bootloader because
no changes were made to the kernel
    

Actual Results:  It will indicate that no changes were made to the
bootloader because no changes were made to the kernel

Expected Results:  No changes are made to the kernel, however the
bootloader is installed on the MBR as expected.

Additional info:
Comment 1 Jeremy Katz 2003-11-10 16:41:33 EST
This is intentional -- we can't create a boot loader configuration
without installing a kernel to give us information on what kernel
should be used in the boot loader config, etc.
Comment 2 Neil Weisenfeld 2003-11-10 18:33:08 EST
Hmmm.. would be useful to just make it with the defaults for the
already installed.  Otherwise the only way for a novice user to do
this is with the grub command line interface which isn't, IMHO,
terribly friendly or safe.


Regards,
Neil
Comment 3 Barry K. Nathan 2003-12-17 01:39:52 EST
Jeremy, the logical expectation (from a sysadmin standpoint) is that
it would try to get the information from at least one of the installed
kernels, in the event that no new kernel is being installed.

(If GRUB could be installed, *with* a new grub.conf as well, with a
separate userspace utility, that would also do the job.)

Note You need to log in before you can comment on or make changes to this bug.