Bug 109608 - "Error installing packages" when attempting to install RPMs from Nautilus or Add/Remove Applications
"Error installing packages" when attempting to install RPMs from Nautilus or ...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-10 01:50 EST by JF
Modified: 2007-11-30 17:10 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-11-22 11:03:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description JF 2003-11-10 01:50:07 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1)
Gecko/20031030

Description of problem:
I'm attempting to install the Kernel Development packages using the
Add/Remove programs interface. I check the box then click update. The
right CD is in the drive, it starts updating then pops up a window saying:

---
Error installing packages

There was an error installing packages.

Exiting.
---

I have two CDROM drives, but the CD is in the drive that RPM seems to
be searching in.

I attempted to install a third party flash RPM (from:
http://ruslug.rutgers.edu/macromedia/site_ru.html -- Fedora Core 0.95
package) and got the same error once RPM went to look for the packages
on CD. I'm pretty sure my CD's are error free. I had absolutely no
problems during installation.

Could it be the failed install of the flash RPM somehow corrupted the
RPM database and this is what is causing the problem?

Version-Release number of selected component (if applicable):
rpm-4.2.1-0.30

How reproducible:
Always

Steps to Reproduce:
1. Download the flash RPM mentioned above
2. Open the RPM in Nautilus and wait for RPM to prompt for CD to
   install packages from
3. Observe the "Error installing packages" error
    

Actual Results:  Step 3. happens

Expected Results:  Required packages from Fedora CDROM should install
successfully

Additional info: None
Comment 1 Davis Webster 2003-11-12 02:07:57 EST
I have the same error also.  I have tested all 3 cd's and they all
passed.  Nothing in add/remove applications will work correctly. 
Everytime I try to add something I recieve the "Error installing
packages" error.  When I went to install 2 other rpm's I have revieved
teh same error.  other rpm's were flash from the same site as above
and compact-c++.  I tried to manually install flash and mozilla also
did you pull the plugins.

steps to repeat...try to add a package or try to add a plugin.  non of
them work.

i think the error might be with permissions...I did notice that sun
one studio kept saying I was not root when I was...also it might
expalin why it cannot gain access to install the rpm's
Comment 2 Brian Kerley 2003-11-12 11:48:23 EST
I have determined what it is on my own.  The add/remove applications
searches the cd's for a folder called "Redhat" as in,
/mnt/cdrom/Redhat/.... but what the cd's have on them is the folder
Fedora instead.  So what you have is /mnt/cdrom/Fedora/..... All that
needs to be done to fix this problem is update the configuration file
for redhat-config-packages somehow.  I have no clue how to though.  So
it may be a simple matter of changing the code and recompiling an rpm
for the Fedora dev's, or sending out an updated config file.
Comment 3 Terry Johnson 2003-11-13 00:21:30 EST
I too have the same bug, however I was able to update the packages by
inserting disc1 and going about it that way. No other problems so far!
Comment 4 Colin Charles 2003-11-13 20:50:09 EST
Is there no resolution to this at the moment? I've tested it on two
systems, and the errors are reproducable.

In /usr/share/redhat-config-packages/, the files that need to be
changed are:
GroupSet.py
method.py

From the usual "RedHat/RPMS" to "Fedora/RPMS".
Comment 5 Colin Charles 2003-11-13 20:55:32 EST
It has been fixed:
http://people.redhat.com/~katzj/redhat-config-packages/
Comment 6 JF 2003-11-14 17:24:15 EST
I downloaded and installed the new redhat-config-packages as mentioned
above. The bug appears to be fixed when the correct CD-ROM is in the
drive. But when the program prompts the user to insert another CD-ROM
the same error message pops up. This appears to be due to errors
mounting and unmounting the CD-ROM drive. Though I'm not exactly sure
what could be going wrong here, looking at the code that
mounts/unmounts the drive could be a good place to start looking for
this bug. Because when you enter a Fedora CD it gets mounted
automatically, perhaps redhat-config-packages is expecting to mount
the CD itself, could this be what is throwing some sort of uncaught
exception?
Comment 7 Jeff Johnson 2003-11-22 11:03:14 EST
If the problem is which CDROM is mounted, then this is a
redhat-config-packages, not rpm, problem.

Note You need to log in before you can comment on or make changes to this bug.