Bug 109613 - No mouse when using gpm with rhgb sometimes
No mouse when using gpm with rhgb sometimes
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: gpm (Show other bugs)
1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Eido Inoue
David Lawrence
:
: 106982 108139 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-10 05:06 EST by Yovko Lambrev
Modified: 2007-11-30 17:10 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-02-20 17:42:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Yovko Lambrev 2003-11-10 05:06:20 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20031016

Description of problem:
The problem is stupid but sometimes after rhgb finished and I recieve
gdm login screen I have no mouse at all. I can find the followig in my
/var/log/messages:

Nov 10 09:29:25 eos gpm: gpm startup succeeded
...
Nov 10 09:29:47 eos gpm[778]: O0o.oops(): [gpm.c(949)]:
Nov 10 09:29:47 eos gpm[778]: mouse initialization failed

My gpm process looks like gpm -m /dev/psaux -t imps2 when it works...

Sometimes my mouse works but with strange habit (pointer jumps and
going me crazy). Sometimes everything is OK but only in X. I have
never working gpm mouse in console after rhgb...

Version-Release number of selected component (if applicable):
gpm-1.20.1-38

How reproducible:
Sometimes

Steps to Reproduce:
1. Boot with rhgb
2. Wait for gdm login screen


Actual Results:  30% mouse just won't work, 40% works bad (crazy
pointer), 30% everything is OK

Additional info:

I've just deinstalled rhgb... 

rpm -e rhgb 

and everything is OK now
Comment 1 Eido Inoue 2003-11-10 15:40:58 EST
what does the mouse configuration in /etc/X11/XFConfig look like?
(just the sections related to the mouse/mice)
Comment 2 Yovko Lambrev 2003-11-11 03:57:59 EST
Section "InputDevice"
        Identifier  "Mouse0"
        Driver      "mouse"
        Option      "Protocol" "IMPS/2"
        Option      "Device" "/dev/psaux"
        Option      "ZAxisMapping" "4 5"
        Option      "Emulate3Buttons" "no"
EndSection

Section "InputDevice"
                                                                     
          # If the normal CorePointer mouse is not a USB mouse then
# this input device can be used in AlwaysCore mode to let you
# also use USB mice at the same time.
        Identifier  "DevInputMice"
        Driver      "mouse"
        Option      "Protocol" "IMPS/2"
        Option      "Device" "/dev/input/mice"
        Option      "ZAxisMapping" "4 5"
        Option      "Emulate3Buttons" "no"
EndSection

My mouse is Logitech Optical PS/2 Wheel
Comment 3 Yovko Lambrev 2003-11-11 03:58:52 EST
Section "ServerLayout"
        Identifier     "Default Layout"
        Screen      0  "Screen0" 0 0
        InputDevice    "Mouse0" "CorePointer"
        InputDevice    "Keyboard0" "CoreKeyboard"
        InputDevice    "DevInputMice" "AlwaysCore"
EndSection
Comment 4 Łukasz Trąbiński 2003-11-15 16:31:47 EST
I confirm this bug, when I try restart gpm in log file I get something
like this:

Nov 10 00:07:49 lt gpm: gpm shutdown failed
Nov 10 00:07:49 lt gpm[6262]: O0o.oops(): [gpm.c(949)]: 
Nov 10 00:07:49 lt gpm[6262]: mouse initialization failed
Nov 10 00:07:49 lt gpm: O0o.oops(): [gpm.c(949)]: 
Nov 10 00:07:49 lt gpm: gpm startup succeeded

lt:~# ps -ef |grep gpm
root      3200     1  0 20:49 ?        00:00:00 gpm -m /dev/mouse -t imps2

Below is my mouse section taken from XF86Config:

Section "InputDevice"
        Identifier  "Mouse0"
        Driver      "mouse"
        Option      "Device" "/dev/mouse"
        Option      "Protocol" "IMPS/2"
        Option      "Emulate3Buttons" "off"
        Option      "ZAxisMapping" "4 5"
EndSection
Comment 5 Arvind Narayanan 2003-11-24 08:14:50 EST
I have this problem too. Mouse is PS/2 Wheel. In my case it didn't
work even once. Is it possible to start gpm before rhgb?
Comment 6 Eido Inoue 2004-02-20 15:30:44 EST
*** Bug 108139 has been marked as a duplicate of this bug. ***
Comment 7 Eido Inoue 2004-02-20 17:42:57 EST
gpm seems to behave much better in the current release
(FC2-1.90-test1), including various combinations of killing and
restarting X, it seems relatively stable.
Comment 8 Bart Martens 2004-03-12 01:08:32 EST
*** Bug 106982 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.